x11-misc/lightdm-gtk-greeter: Migrate to 'appindicator' USE
[gentoo.git] / x11-misc / wbarconf / wbarconf-0.7.2.2-r5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 )
6 inherit python-single-r1
7
8 DESCRIPTION="Configuration GUI for x11-misc/wbar"
9 HOMEPAGE="http://koti.kapsi.fi/ighea/wbarconf/"
10 SRC_URI="http://koti.kapsi.fi/ighea/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
16
17 DEPEND="
18         sys-devel/gettext
19 "
20 RDEPEND="
21         ${PYTHON_DEPS}
22         >=x11-misc/wbar-1.3.3
23         $(python_gen_cond_dep '
24                 dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]
25                 dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
26         ')
27 "
28 PATCHES=(
29         "${FILESDIR}"/${P}-install.patch
30 )
31 S="${WORKDIR}/${PN}"
32
33 src_compile() {
34         python_fix_shebang wbarconf
35 }
36
37 src_install() {
38         ./install.sh "${ED}/usr" || die "./install.sh failed"
39         if [[ "${P}" != "${PF}" ]]; then
40                 mv "${ED}"/usr/share/doc/{${P},${PF}} || die
41         fi
42 }