dev-vcs/hg-git-0.9.0_rc1: version bump with mercurial 5.4 support
[gentoo.git] / sys-block / di / di-4.47.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 DESCRIPTION="Disk Information Utility"
8 HOMEPAGE="https://gentoo.com/di/"
9 SRC_URI="https://gentoo.com/di/${P}.tar.gz"
10
11 LICENSE="ZLIB"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
14 IUSE="nls"
15
16 RESTRICT="test" #405205, #405471
17
18 BDEPEND="nls? ( sys-devel/gettext )"
19
20 PATCHES=(
21         "${FILESDIR}"/${PN}-4.33-build.patch
22 )
23
24 src_configure() {
25         emake checkbuild
26         emake -C C config.h
27 }
28
29 src_compile() {
30         emake prefix=/usr CC="$(tc-getCC)" NLS=$(usex nls T F)
31 }
32
33 src_install() {
34         emake install prefix="${D}/usr"
35         # default symlink is broken
36         dosym di /usr/bin/mi
37         dodoc README
38 }