dev-vcs/hg-git-0.9.0_rc1: version bump with mercurial 5.4 support
authorFabian Groffen <grobian@gentoo.org>
Sat, 30 May 2020 20:05:35 +0000 (22:05 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sat, 30 May 2020 20:06:04 +0000 (22:06 +0200)
Closes: https://bugs.gentoo.org/712112
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
dev-vcs/hg-git/Manifest
dev-vcs/hg-git/hg-git-0.9.0_rc1.ebuild [new file with mode: 0644]

index 983d1e81f381e940bf776e7dc609c4799e8358b4..d5e124461a9bcf64ee56043ce77a3362e73ac5ec 100644 (file)
@@ -1,2 +1,3 @@
 DIST hg-git-0.8.13.tar.gz 127399 BLAKE2B 0cf47df27dfc19cb66d546c1647af4f6b112035ee089c42331c0f2c045ead9e9abf796f0ed0747f52efe1452a9a2ccec237ae4c0296173ae283c180ae5cdb75b SHA512 55eed0704dc2829e6f027bc842e69aa5d193c824521e4c96171cecabd0155b0635a06b5ff2be61cdf0fff1bcb075190a324087b4171fba05df8db76527878a4a
 DIST hg-git-0.8.8.tar.gz 98508 BLAKE2B e7636c3809b2be8a7fcce44a72f89f39927a282c34384047036470fc832b34be1922de75a2a9b468ec125ea716263333f5f58e6a0c7de12729b7dd18c68b657a SHA512 c3b28273024f2429ed526354048f0e37d0af6be591020fa3b1e8d1321247d72129f7c8fbcef73e69d60e243a6f86380dc4d89f0e8f913b786ef4497421237aac
+DIST hg-git-0.9.0a1.tar.bz2 128165 BLAKE2B dfe415a26554d6de714b64aa79f771e08f2c7ac02ee42732524b85a6572003bd428ea29823774d5ea4fa0eee251629bcbc78d9421773c312925a0114e51098ff SHA512 43119bacd4bfc169c8403b3d67e14609ada454a7635c50af5db3683ccd36e1d3be2ec0896204f0850b0cb0c09ded24ae723ad3eb6ddc381553f8c2b2ff2c84a1
diff --git a/dev-vcs/hg-git/hg-git-0.9.0_rc1.ebuild b/dev-vcs/hg-git/hg-git-0.9.0_rc1.ebuild
new file mode 100644 (file)
index 0000000..5db03cc
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_rc/a}
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="https://hg-git.github.io https://pypi.org/project/hg-git/"
+SRC_URI="https://foss.heptapod.net/mercurial/hg-git/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+       >=dev-vcs/mercurial-4.3[${PYTHON_USEDEP}]
+       >=dev-python/dulwich-0.19.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"