initial commit: 1.5.0
[systemrescuecd.git] / portage-overlay / sys-block / gparted / gparted-0.5.2.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-block/gparted/gparted-0.3.8.ebuild,v 1.1 2008/07/23 21:49:47 eva Exp $
4
5 inherit eutils gnome2
6
7 DESCRIPTION="Gnome Partition Editor"
8 HOMEPAGE="http://gparted.sourceforge.net/"
9
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="fat gnome hfs jfs kde ntfs reiserfs reiser4 xfs xfce"
16
17 common_depends=">=sys-apps/parted-1.7.1
18                 >=dev-cpp/gtkmm-2.8.0"
19
20 RDEPEND="${common_depends}
21                 kde? ( || ( kde-base/kdesu kde-base/kdebase ) )
22                 fat? ( sys-fs/dosfstools )
23                 ntfs? ( sys-fs/ntfsprogs )
24                 hfs? ( sys-fs/hfsutils )
25                 jfs? ( sys-fs/jfsutils )
26                 reiserfs? ( sys-fs/reiserfsprogs )
27                 reiser4? ( sys-fs/reiser4progs )
28                 xfs? ( sys-fs/xfsprogs sys-fs/xfsdump )"
29
30 DEPEND="${common_depends}
31                 >=sys-devel/gettext-0.17
32                 >=dev-util/pkgconfig-0.12
33                 >=dev-util/intltool-0.35.5"
34
35 src_compile() 
36 {
37         cd "${S}"
38         econf --disable-scrollkeeper --disable-doc
39         emake all || die "make failed"
40 }
41
42 src_install() 
43 {
44         gnome2_src_install
45 }
46