media-sound/lollypop: Version bump 1.2.32
[gentoo.git] / media-sound / lollypop / lollypop-1.2.32.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_6 )
7 PYTHON_REQ_USE="sqlite"
8 inherit python-single-r1 gnome2-utils meson xdg-utils
9
10 DESCRIPTION="Modern music player for GNOME"
11 HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
12 SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
13 KEYWORDS="~amd64"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 REQUIRED_USE=${PYTHON_REQUIRED_USE}
18
19 DEPEND="${PYTHON_DEPS}
20         dev-libs/appstream-glib[introspection]
21         dev-libs/glib:2
22         dev-libs/gobject-introspection[cairo(+)]
23         $(python_gen_cond_dep '
24                 dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
25                 dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
26         ')
27         gnome-base/gnome-common
28         x11-libs/gtk+:3
29 "
30 BDEPEND="${DEPEND}
31         $(python_gen_cond_dep '
32                 dev-python/pkgconfig[${PYTHON_MULTI_USEDEP}]
33         ')
34         dev-util/desktop-file-utils
35         dev-util/itstool
36         dev-util/intltool
37 "
38 RDEPEND="${DEPEND}
39         app-crypt/libsecret[introspection]
40         dev-libs/totem-pl-parser
41         $(python_gen_cond_dep '
42                 dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
43                 dev-python/dbus-python
44                 dev-python/pillow[${PYTHON_MULTI_USEDEP}]
45                 >=dev-python/pylast-1.0.0[${PYTHON_MULTI_USEDEP}]
46         ')
47         media-libs/gst-plugins-base:1.0[introspection]
48 "
49
50 RESTRICT="test"
51
52 pkg_preinst() {
53         gnome2_schemas_savelist
54 }
55
56 src_install() {
57         meson_src_install
58         python_optimize
59 }
60
61 pkg_postinst() {
62         gnome2_gconf_install
63         gnome2_schemas_update
64         xdg_desktop_database_update
65 }
66
67 pkg_postrm() {
68         gnome2_gconf_uninstall
69         gnome2_schemas_update
70         xdg_desktop_database_update
71 }