dev-vcs/hg-git-0.9.0_rc1: version bump with mercurial 5.4 support
[gentoo.git] / mail-filter / afew / afew-1.3.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DISTUTILS_SINGLE_IMPL=1
7 PYTHON_COMPAT=( python{3_6,3_7} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Initial tagging script for Notmuch"
12 HOMEPAGE="https://github.com/afewmail/afew"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="ISC"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="
21         $(python_gen_cond_dep '
22                 dev-python/chardet[${PYTHON_MULTI_USEDEP}]
23                 dev-python/dkimpy[${PYTHON_MULTI_USEDEP}]
24                 net-mail/notmuch[python,${PYTHON_MULTI_USEDEP}]
25         ')"
26
27 DOCS=( "README.rst" )
28
29 src_prepare() {
30         sed -r \
31                 -e "s/^([[:space:]]+)use_scm_version=.*,$/\1version='${PV}',/" \
32                 -e "/^([[:space:]]+)setup_requires=.*,$/d" \
33                 -i setup.py || die
34         distutils-r1_src_prepare
35 }
36
37 src_install() {
38         distutils-r1_src_install
39         dodoc afew/defaults/afew.config
40 }