gui-apps/kanshi: autorandr for wayland clients
[gentoo.git] / gui-apps / kanshi / kanshi-1.1.0.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit meson
7
8 DESCRIPTION="dynamic display configuration (autorandr for wayland)"
9 HOMEPAGE="https://github.com/emersion/kanshi"
10
11 if [[ ${PV} == 9999 ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/emersion/kanshi"
14 else
15         SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
16         KEYWORDS="~amd64 ~arm64 ~x86"
17 fi
18
19 LICENSE="MIT"
20 SLOT="0"
21 IUSE="+man"
22
23 RDEPEND="
24         dev-libs/wayland
25 "
26 BDEPEND="
27         ${RDEPEND}
28         virtual/pkgconfig
29         dev-libs/wayland-protocols
30 "
31
32 if [[ ${PV} == 9999 ]]; then
33         BDEPEND+="man? ( ~app-text/scdoc-9999 )"
34 else
35         BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
36 fi
37
38 src_configure() {
39         local emesonargs=(
40                 $(meson_feature man man-pages)
41         )
42         meson_src_configure
43 }