dev-libs/cgilib: Drop autotools-utils.eclass
[gentoo.git] / dev-libs / cgilib / cgilib-0.7-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 DESCRIPTION="A simple and lightweight interface to the CGI for C and C++ programs"
8 HOMEPAGE="http://www.infodrom.org/projects/cgilib/"
9 SRC_URI="${HOMEPAGE}download/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
14 IUSE="static-libs"
15
16 DOCS=( AUTHORS ChangeLog README cookies.txt )
17
18 src_prepare() {
19         default
20         eautoreconf
21 }
22
23 src_configure() {
24         econf \
25                 $(use_enable static-libs static)
26 }