dev-java/openjdk: bump to 11.0.7_p10
[gentoo.git] / dev-java / bcprov / bcprov-1.50-r4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source test"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 MY_P="${PN}-jdk15on-${PV/./}"
11
12 DESCRIPTION="Java cryptography APIs"
13 HOMEPAGE="http://www.bouncycastle.org/java.html"
14 SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="1.50"
18 KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
19
20 DEPEND=">=virtual/jdk-1.6
21         app-arch/unzip"
22
23 RDEPEND=">=virtual/jre-1.6"
24
25 S="${WORKDIR}/${MY_P}"
26
27 JAVA_ENCODING="ISO-8859-1"
28
29 # Package can't be built with test as bcprov and bcpkix can't be built with test.
30 RESTRICT="test"
31
32 src_unpack() {
33         default
34         cd "${S}"
35         unpack ./src.zip
36 }
37
38 java_prepare() {
39         if ! use test; then
40                 # There are too many files to delete so we won't be using JAVA_RM_FILES
41                 # (it produces a lot of output).
42                 local RM_TEST_FILES=()
43                 while read -d $'\0' -r file; do
44                         RM_TEST_FILES+=("${file}")
45                 done < <(find . -name "*Test*.java" -type f -print0)
46                 while read -d $'\0' -r file; do
47                         RM_TEST_FILES+=("${file}")
48                 done < <(find . -name "*Mock*.java" -type f -print0)
49
50                 rm -v "${RM_TEST_FILES[@]}" || die
51         fi
52 }
53
54 src_compile() {
55         java-pkg-simple_src_compile
56 }
57
58 src_install() {
59         java-pkg-simple_src_install
60         use source && java-pkg_dosrc org
61 }