dev-java/openjdk: bump to 11.0.7_p10
[gentoo.git] / dev-java / bcprov / bcprov-1.50-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source test"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 MY_P="${PN}-jdk15on-${PV/./}"
11
12 DESCRIPTION="Java cryptography APIs"
13 HOMEPAGE="http://www.bouncycastle.org/java.html"
14 SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="1.50"
18 KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
19
20 CDEPEND=""
21
22 DEPEND=">=virtual/jdk-1.6
23         app-arch/unzip
24         ${CDEPEND}"
25
26 RDEPEND=">=virtual/jre-1.6
27         ${CDEPEND}"
28
29 S="${WORKDIR}/${MY_P}"
30
31 JAVA_ENCODING="ISO-8859-1"
32
33 # Package can't be built with test as bcprov and bcpkix can't be built with test.
34 RESTRICT="test"
35
36 src_unpack() {
37         default
38         cd "${S}"
39         unpack ./src.zip
40 }
41
42 java_prepare() {
43         if ! use test; then
44                 # There are too many files to delete so we won't be using JAVA_RM_FILES
45                 # (it produces a lot of output).
46                 local RM_TEST_FILES=()
47                 while read -d $'\0' -r file; do
48                         RM_TEST_FILES+=("${file}")
49                 done < <(find . -name "*Test*.java" -type f -print0)
50                 while read -d $'\0' -r file; do
51                         RM_TEST_FILES+=("${file}")
52                 done < <(find . -name "*Mock*.java" -type f -print0)
53
54                 rm -v "${RM_TEST_FILES[@]}"
55         fi
56 }
57
58 src_compile() {
59         java-pkg-simple_src_compile
60 }
61
62 src_install() {
63         java-pkg-simple_src_install
64         use source && java-pkg_dosrc org
65 }