dev-embedded/sunxi-tools: Version bump to 1.3; all ebuild work by Alexander Nigl...
[gentoo.git] / dev-embedded / sunxi-tools / sunxi-tools-1.3.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="6"
6
7 inherit eutils toolchain-funcs
8
9 MY_PV="v${PV}"
10 SRC_URI="https://github.com/linux-sunxi/sunxi-tools/archive/${MY_PV}.tar.gz"
11
12 DESCRIPTION="Tools for Allwinner A10 devices."
13 HOMEPAGE="http://linux-sunxi.org/"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 IUSE=""
18 KEYWORDS="~amd64"
19
20 DEPEND="virtual/libusb"
21
22 src_compile() {
23         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" all misc
24 }
25
26 src_install() {
27         dobin bin2fex fex2bin phoenix_info
28         newbin sunxi-bootinfo bootinfo
29         newbin sunxi-fel fel
30         newbin sunxi-fexc fexc
31         newbin sunxi-nand-part nand-part
32         newbin sunxi-pio pio
33 }