dev-embedded/libjaylink: add a snapshot from git so we can add openocd 0.10.0
[gentoo.git] / dev-embedded / libjaylink / libjaylink-0.1.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="6"
6
7 inherit autotools eutils
8
9 DESCRIPTION="Library to access J-Link devices"
10 HOMEPAGE="http://git.zapb.de/libjaylink.git"
11
12 SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~x86"
17 IUSE="static-libs"
18
19 DEPEND="virtual/libusb:1"
20 RDEPEND="${DEPEND}"
21
22 src_prepare() {
23         eapply_user
24         eautoreconf || die
25 }
26
27 src_configure() {
28         econf $(use_enable static-libs static)
29 }
30
31 src_install() {
32         default
33         prune_libtool_files
34 }