app-shells/bashdb: Bump to version 5.0.1.1.0
[gentoo.git] / app-shells / bashdb / bashdb-4.4.1.0.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 MY_P="${PN}-${PV:0:3}-${PV:4}"
7 DESCRIPTION="bash source code debugging"
8 HOMEPAGE="http://bashdb.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2
10         test? ( https://dev.gentoo.org/~whissi/dist/bashdb/bashdb-4.4-1.0.0-missing-test-files.tar.xz )"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
15 IUSE="test"
16
17 DEPEND="!>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))"
18
19 S="${WORKDIR}/${MY_P}"
20
21 src_prepare() {
22         if use test ; then
23                 einfo "Copying missing files ..."
24                 # https://sourceforge.net/p/bashdb/bugs/52/
25                 cp -vafn "${WORKDIR}"/missing-files/* "${S}"/test || die
26         fi
27
28         default
29
30         # We don't install this, so don't bother building it. #468044
31         sed -i 's:texi2html:true:' doc/Makefile.in || die
32 }
33
34 src_configure() {
35         # This path matches the bash sources.  If we ever change bash,
36         # we'll probably have to change this to match.  #591994
37         econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
38 }