app-emacs/nxml-gentoo-schemas: Version bump to 20200229.
[gentoo.git] / app-emacs / mew / mew-6.8.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 NEED_EMACS=24
6
7 inherit elisp readme.gentoo-r1
8
9 DESCRIPTION="Great MIME mail reader for Emacs/XEmacs"
10 HOMEPAGE="https://www.mew.org/"
11 SRC_URI="https://www.mew.org/Release/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 ppc x86"
16 IUSE="ssl l10n_ja"
17 RESTRICT="test"
18
19 DEPEND="sys-libs/zlib"
20 RDEPEND="${DEPEND}
21         ssl? ( net-misc/stunnel )"
22
23 SITEFILE="50${PN}-gentoo.el"
24
25 src_configure() {
26         econf \
27                 --with-elispdir="${SITELISP}/${PN}" \
28                 --with-etcdir="${SITEETC}/${PN}"
29 }
30
31 src_compile() {
32         emake
33         use l10n_ja && emake jinfo
34         rm -f info/*~                           # remove spurious backup files
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" install
39         use l10n_ja && emake DESTDIR="${D}" install-jinfo
40         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
41         dodoc 00api 00changes* 00diff 00readme dot.*
42
43         DOC_CONTENTS="Please refer to /usr/share/doc/${PF} for sample
44                 configuration files."
45         readme.gentoo_create_doc
46 }