app-emacs/nxml-gentoo-schemas: Version bump to 20200229.
[gentoo.git] / app-emacs / emacs-w3m / emacs-w3m-1.4.632_pre20181112.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp autotools readme.gentoo-r1
7
8 DESCRIPTION="emacs-w3m is an interface program of w3m on Emacs"
9 HOMEPAGE="http://emacs-w3m.namazu.org/"
10 SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
15 IUSE="gzip-el l10n_ja"
16
17 RDEPEND="virtual/w3m"
18 BDEPEND="${RDEPEND}"
19
20 S="${WORKDIR}/${PN}"
21 SITEFILE="70${PN}-gentoo.el"
22
23 src_prepare() {
24         mv configure.{in,ac} || die
25         sed -i -e '/^configure:/,+2d' Makefile.in || die
26         eapply_user
27         eautoreconf
28 }
29
30 src_configure() {
31         econf --without-compress-install
32 }
33
34 src_compile() {
35         emake all-en $(use l10n_ja && echo all-ja)
36 }
37
38 src_install() {
39         emake lispdir="${ED}${SITELISP}/${PN}" \
40                 COMPRESS_INSTALL=$(usex gzip-el) \
41                 install-lisp
42         emake infodir="${ED}/usr/share/info" \
43                 ICONDIR="${ED}${SITEETC}/${PN}" \
44                 install-info-en $(use l10n_ja && echo install-info-ja) install-icons
45
46         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
47         dodoc ChangeLog* NEWS README
48         use l10n_ja && dodoc BUGS.ja NEWS.ja README.ja
49
50         DOC_CONTENTS="If you want to use the shimbun library, please emerge
51                 app-emacs/apel and app-emacs/flim."
52         readme.gentoo_create_doc
53 }