Add ASTranslate ebuild (much like the ASDictionary ebuild).
[wtk-prefix-overlay.git] / dev-python / astranslate / astranslate-9999.ebuild
diff --git a/dev-python/astranslate/astranslate-9999.ebuild b/dev-python/astranslate/astranslate-9999.ebuild
new file mode 100644 (file)
index 0000000..f6817be
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit subversion python
+
+MY_PN="ASTranslate"
+
+DESCRIPTION="Convert AppleScript into its appscript equivalent"
+HOMEPAGE="http://appscript.sourceforge.net"
+SRC_URI=""
+ESVN_REPO_URI="https://appscript.svn.sourceforge.net/svnroot/appscript/${MY_PN}/trunk/src"
+LICENSE="public-domain"
+KEYWORDS="~x64-macos ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/setuptools-0.6.14
+       >=dev-python/appscript-0.22.0
+       >=dev-python/osaterminology-0.14.6
+       >=virtual/pyobjc-1.4
+       >=dev-python/py2app-0.5.2"
+RDEPEND="$DEPEND"
+
+src_compile() {
+       python setup.py py2app
+}
+
+src_install() {
+  APP_DIR="${ED}Applications"
+       mkdir -p "${APP_DIR}"
+       cp -rp "dist/${MY_PN}.app" "${APP_DIR}"
+}