Add asdictionary and dependencies.
[wtk-prefix-overlay.git] / dev-python / asdictionary / asdictionary-9999.ebuild
diff --git a/dev-python/asdictionary/asdictionary-9999.ebuild b/dev-python/asdictionary/asdictionary-9999.ebuild
new file mode 100644 (file)
index 0000000..d08821b
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit subversion python
+
+MY_PN="ASDictionary"
+
+DESCRIPTION="Exports scriptable applications' terminology in AppleScript and appscript formats"
+HOMEPAGE="http://appscript.sourceforge.net"
+SRC_URI=""
+ESVN_REPO_URI="https://appscript.svn.sourceforge.net/svnroot/appscript"
+LICENSE="public-domain"
+KEYWORDS="~x64-macos ~x86"
+SLOT="0"
+IUSE=""
+S="${WORKDIR}/${MY_PN}/trunk/src"
+
+DEPEND=">=dev-python/setuptools-0.6.14
+       >=dev-python/htmltemplate-1.5.0
+       >=dev-python/appscript-0.22.0
+       >=dev-python/aemreceive-0.4.0
+       >=dev-python/osaterminology-0.14.6
+       >=virtual/pyobjc-1.4
+       >=dev-python/py2app-0.5.2"
+RDEPEND="$DEPEND"
+
+src_compile() {
+       python setup.py py2app
+}
+
+src_install() {
+       insinto /usr/local/apps
+       doins -r dist
+}