Add asdictionary and dependencies.
[wtk-prefix-overlay.git] / dev-python / asdictionary / asdictionary-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="*"
8 SUPPORT_PYTHON_ABIS="1"
9
10 inherit subversion python
11
12 MY_PN="ASDictionary"
13
14 DESCRIPTION="Exports scriptable applications' terminology in AppleScript and appscript formats"
15 HOMEPAGE="http://appscript.sourceforge.net"
16 SRC_URI=""
17 ESVN_REPO_URI="https://appscript.svn.sourceforge.net/svnroot/appscript"
18 LICENSE="public-domain"
19 KEYWORDS="~x64-macos ~x86"
20 SLOT="0"
21 IUSE=""
22 S="${WORKDIR}/${MY_PN}/trunk/src"
23
24 DEPEND=">=dev-python/setuptools-0.6.14
25         >=dev-python/htmltemplate-1.5.0
26         >=dev-python/appscript-0.22.0
27         >=dev-python/aemreceive-0.4.0
28         >=dev-python/osaterminology-0.14.6
29         >=virtual/pyobjc-1.4
30         >=dev-python/py2app-0.5.2"
31 RDEPEND="$DEPEND"
32
33 src_compile() {
34         python setup.py py2app
35 }
36
37 src_install() {
38         insinto /usr/local/apps
39         doins -r dist
40 }