Add ~x64-macos to all package KEYWORDS.
[wtk-prefix-overlay.git] / app-portage / g-pypi / g-pypi-0.2.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="*:2.6"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 PYTHON_MODNAME="g_pypi"
12
13 inherit distutils
14
15 DESCRIPTION="Tool for creating Gentoo ebuilds for Python packages by querying PyPI (The Cheese Shop)"
16 HOMEPAGE="http://code.google.com/p/${PN}/"
17 SRC_URI="mirror://pypi/{$PN:0:1}/${PN}/${P}.tar.gz"
18 LICENSE="GPL-2"
19 KEYWORDS="~amd64 ~x64-macos ~x86"
20 SLOT="0"
21 IUSE="test doc"
22 DEPEND="dev-python/setuptools
23         test? ( dev-python/nose )"
24 RDEPEND="dev-python/pygments
25         dev-python/setuptools
26         dev-python/cheetah
27         dev-python/configobj
28         app-portage/gentoolkit
29         dev-python/yolk"
30
31 src_install() {
32         distutils_src_install
33         if use doc; then
34                 dodoc "${S}"/docs/*
35         fi
36
37 }
38
39 src_test() {
40         PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
41 }