webtest-*.ebuild: Install lint3 for Python 3
[wtk-overlay.git] / webtest-1.4.3.ebuild
index 3b010e9309c65838a345ce3c8446a192f6467f35..eb7fd42b0655e40c802604db13dc227e5e17f1f4 100644 (file)
@@ -20,7 +20,7 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ia64 ppc ppc64 ~s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm ~hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
 IUSE="doc"
 
 RDEPEND=">=dev-python/webob-0.9.2"
@@ -44,13 +44,6 @@ src_compile() {
 src_install() {
        distutils_src_install
 
-       # Avoid future-import bug on py2.5.* - lint3 is py3 anyway
-       delete_lint3() {
-               [[ "${PYTHON_ABI}" == 3.* ]] && return
-               rm "${ED}$(python_get_sitedir)/webtest/lint3.py"
-       }
-       python_execute_function -q delete_lint3
-
        if use doc; then
                dohtml -r html/*
        fi