webtest-*.ebuild: Install lint3 for Python 3
[wtk-overlay.git] / webtest-1.4.3-r1.ebuild
index bd27baeb112fc8c614bfdb50ac766aafe2602d36..0799644801144a34b557da5902c7b52bd1f2655c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header$
 
@@ -17,8 +17,9 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ppc ~ppc64 s390 ~sh ~sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm ~hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd"
 IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND=">=dev-python/webob-0.9.2[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
@@ -26,9 +27,11 @@ DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/pyquery[${PYTHON_USEDEP}] )"
+               dev-python/pyquery[${PYTHON_USEDEP}]
+               virtual/python-unittest2[${PYTHON_USEDEP}] )"
 
 S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/webtest-1.4.3-doctest.patch" )
 
 python_compile_all() {
        if use doc; then
@@ -36,16 +39,14 @@ python_compile_all() {
        fi
 }
 
-python_test() {
-       nosetests || die "Tests fail with ${EPYTHON}"
+src_test() {
+       DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
 }
 
-python_install() {
-       distutils-r1_python_install
-
-       if [[ ${EPYTHON} == python3* ]]; then
-               rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
-       fi
+python_test() {
+       # Tests raise ImportErrors with our default PYTHONPATH.
+       unset PYTHONPATH
+       nosetests || die "Tests fail with ${EPYTHON}"
 }
 
 python_install_all() {