net-mail/rss2email: add live ebuild with my ConfigParser updates.
[wtk-overlay.git] / net-mail / rss2email / rss2email-9999.ebuild
diff --git a/net-mail/rss2email/rss2email-9999.ebuild b/net-mail/rss2email/rss2email-9999.ebuild
new file mode 100644 (file)
index 0000000..2af19a7
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+PYTHON_DEPEND="3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.* 3.[01]"
+
+inherit eutils distutils
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit git-2
+       EGIT_BRANCH="master"
+       EGIT_REPO_URI="git://tremily.us/${PN}.git"
+       SRC_URI=""
+else
+       #SRC_URI="http://git.tremily.us/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz"
+       SRC_URI="http://www.allthingsrss.com/${PN}/${P}.tar.gz
+               mirror://debian/pool/main/r/${PN}/${PN}_${DEBIAN_PV}-1.diff.gz"
+fi
+
+DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
+HOMEPAGE="http://www.allthingsrss.com/rss2email"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/feedparser-5.0.1
+       >=dev-python/html2text-3.01"
+
+src_install() {
+       distutils_src_install
+       dodoc CHANGELOG README
+       doman r2e.1
+}