Merge branch 'dev-python/pyssim'
[wtk-overlay.git] / dev-python / pyssim / pyssim-9999.ebuild
diff --git a/dev-python/pyssim/pyssim-9999.ebuild b/dev-python/pyssim/pyssim-9999.ebuild
new file mode 100644 (file)
index 0000000..2eb0c70
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="git://github.com/jterrace/${PN}.git"
+       SRC_URI=""
+else
+       SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="Implements the Structural Similarity Image Metric (SSIM)"
+HOMEPAGE="https://github.com/jterrace/pyssim https://pypi.python.org/pypi/pyssim"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/numpy[${PYTHON_USEDEP}]
+       dev-python/pillow[${PYTHON_USEDEP}]
+       sci-libs/scipy[${PYTHON_USEDEP}]
+       "
+
+DEPEND="${RDEPEND}"