Merge branch 'dev-python/pyassuan'
[wtk-overlay.git] / dev-python / pyassuan / pyassuan-9999.ebuild
index e66cb1a81385e35b2aa9f8dc7694390fa33b5a10..2742968d2c7f4dd808097cda574ddb0bde1bc5fd 100644 (file)
@@ -2,16 +2,13 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="4"
-PYTHON_DEPEND="3:3.3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.* 3.[012]"
+EAPI="6"
+PYTHON_COMPAT=( python{3_3,3_4,3_5,3_6} )
 
-inherit eutils distutils
+inherit eutils distutils-r1
 
 if [[ ${PV} == "9999" ]] ; then
-       inherit git-2
-       EGIT_BRANCH="master"
+       inherit git-r3
        EGIT_REPO_URI="git://tremily.us/${PN}.git"
        SRC_URI=""
 else
@@ -27,12 +24,11 @@ KEYWORDS="~amd64 ~x86"
 IUSE="doc test"
 
 RDEPEND=""
-DEPEND="${RDEPEND}
-       test? ( dev-python/nose )"
+DEPEND="${RDEPEND}"
 
 src_unpack() {
        if [[ ${PV} == "9999" ]] ; then
-               git-2_src_unpack
+               git-r3_src_unpack
        else
                unpack ${A}
        fi
@@ -40,6 +36,6 @@ src_unpack() {
 }
 
 src_install() {
-       distutils_src_install
+       distutils-r1_src_install
        dodoc README
 }