Add ~amd64 keyword to curses-check-for-keypress, and update to git-2 and EAPI 4.
[wtk-overlay.git] / dev-python / curses-check-for-keypress / curses-check-for-keypress-9999.ebuild
index 03012441638a2acd1422aa642b16a7c3e6ec11bf..1f433cba65d803d661ea78bacd55b0098610fe27 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI="3"
+EAPI="4"
 PYTHON_DEPEND="2:2.6"
 SUPPORT_PYTHON_ABIS="1"
 RESTRICT_PYTHON_ABIS="3.*"
@@ -12,7 +12,7 @@ inherit eutils distutils
 MY_PN="curses_check_for_keypress" #${PN/-/_}"
 
 if [[ ${PV} == "9999" ]] ; then
-       inherit git
+       inherit git-2
        EGIT_REPO_URI="http://www.physics.drexel.edu/~wking/code/git/${MY_PN}.git"
        SRC_URI=""
 else
@@ -24,12 +24,12 @@ HOMEPAGE="http://www.physics.drexel.edu/~wking/unfolding-disasters/posts/${MY_PN
 
 LICENSE="public-domain"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
 IUSE="test"
 
 src_unpack() {
        if [[ ${PV} == "9999" ]] ; then
-               git_src_unpack
+               git-2_src_unpack
        else
                unpack ${A}
        fi