link to remote setup
[ikiwiki.git] / doc / setup / discussion.mdwn
1 I have copied over the ikiwiki.setup file from /usr/share/doc/ikiwiki/ to /etc/ikiwiki/ and run it after editing. My site gets built but when I click on the 'edit' button, firefox and google chrome download the cgi file instead of creating a way to edit it. The permissions on my ikiwiki.cgi script look like this: -rwsr-sr-x  1 root root 13359 2009-10-13 19:21 ikiwiki.cgi. Is there something I should do, i.e. change permissions, so I can get it to run correctly? (jeremiah)
2
3 > Have a look [[here|tips/dot_cgi]]. --[[Jogo]]
4
5 I just went through the standard procedure described for setup, copied the blog directory from examples into my source directory, ran ikiwiki, and everything seems to have worked, except that none of the 
6 [[!meta ... ]] tags get converted. They simply show up in the html files unformatted, with no exclamation point, and with p tags around them. Any ideas? using ikiwiki version 2.40 on freebsd --mjg
7
8 > The meta plugin is not enabled by default. It's pulled in by the
9 > goodstuff plugin, so add one or the other to the add_plugins line in your
10 > config file. --[[Joey]]
11
12 Can the instructions for using `ikiwiki-makerepo` be clarified. This
13 command wants to create folders in the directory it is run in. Which
14 directory should that be - `$SRCDIR?` --Andy
15
16 > No, `ikiwiki-makerepo` does not create directories in the current
17 > directory. You specify the directory you want it to create and it creates
18 > the directory and makes it into a repository. The setup instuctions have
19 > examples of doing this. I don't see anything unclear. --[[Joey]]
20
21 Sorry, was not precise enough. It does if you are using the git option. I
22 believe this is partially explained on the rcs/git/ page. However I'm still
23 not totally clear where I should run the command when using git. If I
24 should be in $SRCDIR then updating the instructions to something like
25
26     REPOSITORY=~/wiki.git
27     cd $SRCDIR
28     ikiwiki-makerepo git $SCDIR $REPOSITORY
29
30 might clear things up a little. Apologies if I'm being a bit dim, learning
31 ikiwiki and git at same time :) 
32
33 Have tried 3 options
34
35 1. mkdir $REP cd $REP run command (says $REP already exists so won't run)
36 2. rm -rf $REP cd $SRC run command (creates a repository in $SRC, does not create $REP ends with "remote origin already exists"
37 3. mkdir $TMP cd $TMP run command (creates a repository in $SRC/.git creates a repository in $TMP, does nothing to $REP, ends with "remote origin already exists".
38
39 Version of ikiwiki installed is package from Ubuntu/Hardy 2.19
40 Git version is 1.5.2.5
41
42 n.b. svn version of command worked fine :)
43
44 --Andy
45
46 >       Initialized empty shared Git repository in /home/deploy/tmp/
47 >       Initialized empty Git repository in .git/
48 >       fatal: '/home/deploy/tmp/repo': unable to chdir or not a git archive
49
50 Looks like your git does not support GIT_DIR being used with git-init. I
51 see some mentions of changes in git's changelog for 1.5.3 that look
52 relevant. I've changed ikiwiki-makerepo to use a method more portable to
53 older versions of git. --[[Joey]]
54
55 Many thanks Joey, upgraded my git, and now have working iki :) -- Andy
56
57 ----
58
59 It isn't intended that .ikiwiki be versioned, is it? Do you have a svn:ignore set? 
60 Is there some magic way you can make the svn commands (and presumably commands for 
61 the other VCSs here) ignore the .ikiwiki directory during step 8, when they import it?
62 If not, maybe a note should be made that the user should delete this file before 
63 they import. --Ethan
64
65 > No, .ikiwiki should not be versioned, and a svn:ignore of it is reasonable,
66 > although probably too much noise for the setup instructions.
67 > I've switched to a different method that preserves .ikiwiki, w/o checking
68 > it in. --[[Joey]]
69
70 ----
71
72 These instructions should probably show how to use a bare Git repository
73 (`GIT_DIR=somewhere.git git-init-db`) rather than a repository with a full
74 working copy. You can always clone the repository if you want your own local
75 working copy. Furthermore, this allows you to make multiple commits to your
76 working copy before pushing them to the repository and causing the wiki to
77 update. --[[JoshTriplett]]
78
79 > I'm currently testing and running such a setup. --[[tschwinge]]
80
81 Furthermore the git instructions should be changed to move the *.ikiwiki*
82 directory back into the wiki's working copy directory, isn't it? --[[tschwinge]]
83
84 > Yes, I think so.  I will clean these instructions up unless somebody tells me we're missing something fundamental. --[[BartMassey]]
85
86 >> Either you do it or I'll do it somewhen soon.  --[[tschwinge]]
87
88 ----
89
90 Curious as to why support for CVS is not built in. --[[Luther]]
91
92 > See [[todo/CVS_backend|todo/CVS_backend]], but you might consider switching to a better version control system. --[[JoshTriplett]]
93
94 ----
95
96 What is the syntax for specifying the adminuser as an openid user?  I've tried a couple things but I'm missing something.   Thanks for any pointers.  -- [[AdamShand]]
97
98 > Just put the openid url in there. It has to be the full url with
99 > "http://". --[[Joey]]
100
101 ----
102
103 I apologize if this is the incorrect forum for this question, but I am
104 trying to get ikiwiki set up and running with git.  I followed all the
105 directions and all seems to work until I go back and try to make changes.
106 The steps I am performing:
107
108     cd $SRCDIR  (e.g. ~/ikisrc)
109     vim index.mdwn (add a couple lines)
110     git commit -a -m 'test'
111     git push
112
113 I then get a long error message which reads in part "You asked me to pull
114 without telling me which branch you want to merge with, and
115 'branch.master.merge' in your configuration file does not tell me either."
116 From that point on, I get:
117
118     sws@odin:~/dev/ikisrc$ git push
119     To /home/git/repos/myikiwiki.git
120      ! [rejected]        master -> master (non-fast forward)
121     error: failed to push to '/home/git/repos/myikiwiki.git'
122
123 If I do a git clone ssh://odin/path/to/$REPOSITORY from another machine and
124 try to edit I get the same error sequence.  What am I doing wrong?
125
126 > I don't know. The only time I have seen this message is when
127 > the master git repository was not bare. All current instructions and
128 > `ikiwiki-makerepo` have a proper bare repo used for the master
129 > repository, but perhaps you followed some old, broken instructions, or 
130 > forgot to make it bare? --[[Joey]] 
131
132 -----
133
134 I follow every steps of the setup procedure, change some templates and
135 tried to modify some page through the web but was not able to do so. Every
136 page seems to be locked by the adminuser user. When I remove the adminuser
137 in the setup file, every ran fine. Did I miss something ? What is exactly
138 the adminuser supposed to be allowed to ? Is he the only user allowed to
139 modify pages ?
140
141 > This was a bug in ikwiki that was fixed in version 2.44. --[[Joey]]
142
143 -----
144
145 pI hope you guys can put up with an absolute newbie. I am fairly new to linux and completely new to Perl. I have just installed MoinMoin locally in my PC, running ubuntu 8.4 and was about to use it until I ran into your ikiwiki. I thought ikiwiki is a better fit for what I want to do, so am seriously considering installing it as well in ubuntu. Except that the install seems way beyond my understanding.
146
147 Do i need to install git first? Which git -- the git-core? Ubuntu's instructions on installing the git-core is: "sudo apt-get install git-core". Is that it? Do I need to do a git-init as well, or will the ikiwiki-makerepo handle that? If I have to do a git-init as well, what --share values should I specify?
148
149 It seems I will have to install the ikiwiki from the tar.gz file. I have downloaded it, but do I need to install CPAN or CPAN++ first? That doesn't sound right. I am totally confused already. Does anyone have some install documents pitched to someone as ignorant as I am? -- [[WillDioneda]]
150
151 > Ubuntu includes ikiwiki (in universe, I assume), so you should just be
152 > able to use apt or synaptic to install the package, as documented on the
153 > [[download]] page. Install git-core also to get git.
154
155 > You do not need to use git-init if you use ikiwiki-makrepo. --[[Joey]]
156
157
158 Thanks for your response. You're right. Ubuntu does have ikiwiki, except that it is an older version. I tried installing it; saw some error messages from the install, and decided against it. Plus the documentation here in ikiwiki.info seems slightly different. I made an executive/beginner decision: to go for the latest tarball. And found myself in deep water, ...
159
160 Anyway, I think I might be able to install it from the tarball I downloaded. I've been reading the discussions, had a look at your screencasts, etc. I will give it another bash. -- [[WillDioneda]]
161
162 ----
163
164 How do I set up cgi editing?  In setup I have:
165
166  * cgiurl => 'http://wiki.had.co.nz/edit.cgi'
167  * cgi_wrapper => 'edit.cgi'
168
169 But I don't get an edit link on my pages?  What am I doing wrong?
170
171 > Assuming you don't have the editpage plugin disabled, all you should need
172 > to so is re-run `ikiwiki -setup` with the above config and it should
173 > rebuild your wiki and add the edit links to pages. --[[Joey]]
174
175 ----
176
177 I setup ikiwiki on a fedora 10 machine and I am using apache as my http server. Faced a few difficulties while setting it up as the default setup program left some suid files and group writeable directories on the system. It took some time to get it working and documented what I did at http://flyingtux.blogspot.com/2009/03/installing-ikiwiki.html. Thought it might be useful to someone here. (The version installed is 2.72)
178
179 > ikiwiki makes wrappers suid by default, because this ensures that when
180 > the ikiwiki.cgi is run by your web server, it runs as the user who owns
181 > your wiki, and can thus write to it. ikiwiki is designed to run securely
182 > suid. If your webserver uses some
183 > mechanism to run the ikiwiki.cgi as the user who owns it, without the
184 > suid bit being set, you *could* modify `cgi_wrappermode` in your setup
185 > file to drop the suid bit. 
186
187 > ikiwiki respects the umask, so if your umask is one that causes things to
188 > be group writable, they will by. If you want to override that, there is
189 > also a `umask ` setting in your setup file. --[[Joey]] 
190
191 ----
192
193 /etc/ikiwiki/auto.setup tries to get abs_path of a non-existent
194 "repository" path (in ikiwiki-makerepo), and that doesn't work in my perl:
195
196 <pre>
197 [mort@localhost ~]$ perl -e 'use Cwd q{abs_path}; print abs_path("/var")'
198 /var[mort@localhost ~]$ perl -e 'use Cwd q{abs_path}; print abs_path("/abcde")'
199 [mort@localhost ~]$ 
200 </pre>
201
202 Because of this, /etc/ikiwiki/auto.setup fails: 
203
204 <pre>
205 $ ikiwiki -setup /etc/ikiwiki/auto.setup
206 What will the wiki be named? wiki
207 What revision control system to use? git
208 What wiki user (or openid) will be admin? mort
209
210
211 Setting up wiki ...
212 internal error finding repository abs_path
213 /etc/ikiwiki/auto.setup: failed to set up the repository with ikiwiki-makerepo
214
215 usage: ikiwiki [options] source dest
216        ikiwiki --setup configfile
217 $ perl -v
218
219 This is perl, v5.8.8 built for i386-linux-thread-multi
220 (with 2 registered patches, see perl -V for more detail)
221
222 Copyright 1987-2007, Larry Wall
223
224 Perl may be copied only under the terms of either the Artistic License or the
225 GNU General Public License, which may be found in the Perl 5 source kit.
226
227 Complete documentation for Perl, including FAQ lists, should be found on
228 this system using "man perl" or "perldoc perl".  If you have access to the
229 Internet, point your browser at http://www.perl.org/, the Perl Home Page.
230
231
232 </pre>
233
234 Can't ikiwiki's "make test" perhaps test for this, so that one knows something will go wrong?
235 -- Ivan Z.
236
237 > FWIW, I tried the same thing with perl 5.8.8 from Debian etch, and its
238 > Cwd does not have the problem. But I've modified `ikiwiki-makerepo` to
239 > avoid using `abs_path` this way anyhow. --[[Joey]] 
240
241 Thank you! I'm not a Perl programmer, so what's your opinion: is this behavior a violation of the specification of abs_path and I should report it to [ALTLinux](http://bugs.altlinux.org) (the distro)? --Ivan Z.
242
243 > That is not entirely clear to me from the documentation. It doesn't
244 > say the path has to exist, but doesn't say it cannot either. --[[Joey]]
245
246 I am experiencing the same problem "/etc/ikiwiki/custom: failed to set up the repository with ikiwiki-makerepo
247 " on Debian squeeze with perl5.10.0. Upgrading to ikiwiki 3.10 fixes it. -- [Albert](http://www.docunext.com/)
248
249 ----
250
251 Just a note, perl 5.10 isn't packaged as part of RHEL or thus CentOS nor EPEL,
252 so it's not especially trivial to satisfy that requirement for ikiwiki on
253 those platforms, without backporting it from Fedora or building from source.
254 However, I have an ikiwiki 3.20100403 running on RHEL-4 supplied 5.8.8 without
255 (seemingly too much) complaint.  How strong is the 5.10 requirement? what
256 precicely breaks without it? -- [[Jon]]
257
258 > I don't remember what was the specific problem with perl 5.8.8. All I can
259 > find is some taint checking bugs, which are currently worked around by
260 > taint checking being disabled. --[[Joey]]
261
262 ---
263
264 Did anyone tried to install ikiwiki under a vhost setup ? 
265 ikiwiki is installed under a debian lenny system. but without write acces to /etc/ikiwiki (obvious) i am coming not far.
266 Or do i miss something which is probably hidden deeper in the documentation ?
267
268 Well it should be similar to shared hosting [or a remote server in general](http://ikiwiki.info/forum/how_to_setup_ikiwiki_on_a_remote_host/)
269
270 ----
271 Perhaps it's worth noting that when installing ikiwiki with apt on Debian stable, you need to use the backports version in order to follow the setup instructions.