Move wxversion.select call to hooke.ui.gui and remove evtmgr import.
authorW. Trevor King <wking@tremily.us>
Mon, 20 Aug 2012 17:27:56 +0000 (13:27 -0400)
committerW. Trevor King <wking@tremily.us>
Mon, 20 Aug 2012 17:27:56 +0000 (13:27 -0400)
This ensures wxversion.select gets called before anyone has a change
to import wx.  evtmgr hasn't been used since

  commit bbf2b7eb99e94cf82de4c4160c9fdf8702cd1ba4
  Author: W. Trevor King <wking@drexel.edu>
  Date:   Mon Aug 2 10:56:10 2010 -0400

    Updated gui.panel.note and simplified hooke.plugin.note.

hooke/ui/gui/__init__.py
hooke/ui/gui/interface.py

index dcd7fab..59ea1b7 100644 (file)
@@ -32,6 +32,8 @@ except ImportError, e:
     _wxversion = None
     _wxversion_error = e
 else:
+    WX_GOOD=['2.9']
+    _wxversion.select(WX_GOOD)
     try:
         from .interface import HookeApp as _HookeApp
     except _wxversion.VersionError, e:
index 3ea8631..f157cbd 100644 (file)
 """Define :class:`HookeApp` and related, central application classes.
 """
 
-WX_GOOD=['2.9']
-
-import wxversion
-wxversion.select(WX_GOOD)
-
 import copy
 import logging
 import os
@@ -35,7 +30,6 @@ import wx
 import wx.html
 #import wx.aui as aui         # C++ implementation
 import wx.lib.agw.aui as aui  # Python implementation
-import wx.lib.evtmgr as evtmgr
 # wxPropertyGrid is included in wxPython >= 2.9.1, see
 #   http://wxpropgrid.sourceforge.net/cgi-bin/index?page=download
 # until then, we'll avoid it because of the *nix build problems.