Clean up the tests correctly.
[gpgme.git] / tests / gpg / Makefile.am
index bca36b0ea048a0bf54ff34cdb1a17f8fc408621d..d4debd7c5d5ddbbb3f5e13785e44a86e68200947 100644 (file)
@@ -37,10 +37,11 @@ TESTS = t-encrypt t-encrypt-sym t-encrypt-sign t-sign t-signers             \
        t-import t-trustlist t-edit t-keylist t-keylist-sig t-wait      \
        t-encrypt-large t-file-name t-gpgconf $(tests_unix)
 
-CLEANFILES = secring.gpg pubring.gpg pubring.kbx trustdb.gpg dirmngr.conf
-DISTCLEANFILES = pubring.gpg~ pubring.kbx~ random_seed gpg.conf gpg-agent.conf S.gpg-agent
+CLEANFILES = secring.gpg pubring.gpg pubring.kbx trustdb.gpg dirmngr.conf \
+       gpg-agent.conf pubring.kbx~ S.gpg-agent gpg.conf pubring.gpg~ \
+       random_seed
 
-EXTRA_DIST = mkdemodirs.in pubdemo.asc secdemo.asc cipher-1.asc cipher-2.asc \
+EXTRA_DIST = pubdemo.asc secdemo.asc cipher-1.asc cipher-2.asc \
        geheim.txt pubkey-1.asc seckey-1.asc pinentry
 
 INCLUDES = -I$(top_builddir)/src