Might now build for CE using MSC.
[gpgme.git] / src / Makefile.am
index 41ab762eb6d7ced7381318899ae86ecf323d00c6..0065c073acec790a5fed99e431e4512ea50ed088 100644 (file)
@@ -68,6 +68,10 @@ system_components = ath.h posix-util.c posix-sema.c posix-io.c
 system_components_not_extra =
 endif
 
+if HAVE_W32CE_SYSTEM
+system_components += w32-ce.h w32-ce.c
+endif
+
 if HAVE_GPGSM
 gpgsm_components = engine-gpgsm.c
 else
@@ -98,7 +102,6 @@ else
 uiserver_components = 
 endif
 
-
 # These are the source files common to all library versions.  We used
 # to build a non-installed library for that, but that does not work
 # correctly on all platforms (in particular, one can not specify the
@@ -115,7 +118,7 @@ main_sources =                                                              \
        sign.c passphrase.c progress.c                                  \
        key.c keylist.c trust-item.c trustlist.c                        \
        import.c export.c genkey.c delete.c edit.c getauditlog.c        \
-       opassuan.c                                                      \
+       opassuan.c passwd.c                                             \
        engine.h engine-backend.h engine.c engine-gpg.c status-table.h  \
        $(gpgsm_components) $(assuan_components) $(gpgconf_components)  \
        $(uiserver_components)                                          \
@@ -155,14 +158,17 @@ AM_CPPFLAGS = @GPG_ERROR_CFLAGS@ @PTH_CPPFLAGS@ \
 AM_CFLAGS = @LIBASSUAN_CFLAGS@ @PTH_CFLAGS@ @GLIB_CFLAGS@ @QT4_CORE_CFLAGS@
 
 if HAVE_W32_SYSTEM
-
 # Windows provides us with an endless stream of Tough Love.  To spawn
 # processes with a controlled set of inherited handles, we need a
 # wrapper process.
+# Except on Windows CE.  There nothing is inheritable anyway.
+if HAVE_W32CE_SYSTEM
+libexec_PROGRAMS =
+else
 libexec_PROGRAMS = gpgme-w32spawn
+endif
 
-RCCOMPILE = $(RC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
-       $(AM_CPPFLAGS) $(CPPFLAGS)
+RCCOMPILE = $(RC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES)
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RCCOMPILE)
 
 SUFFIXES = .rc .lo
@@ -196,7 +202,8 @@ libgpgme_la_LDFLAGS = $(no_undefined) $(export_symbols) \
        $(libgpgme_version_script_cmd) -version-info \
        @LIBGPGME_LT_CURRENT@:@LIBGPGME_LT_REVISION@:@LIBGPGME_LT_AGE@
 libgpgme_la_DEPENDENCIES = @LTLIBOBJS@ $(srcdir)/libgpgme.vers $(gpgme_deps)
-libgpgme_la_LIBADD = $(gpgme_res) @LIBASSUAN_LIBS@ @LTLIBOBJS@ @GPG_ERROR_LIBS@
+libgpgme_la_LIBADD = $(gpgme_res) @LIBASSUAN_LIBS@ @LTLIBOBJS@ \
+                    @GPG_ERROR_LIBS@
 
 libgpgme_pthread_la_LDFLAGS = $(no_undefined) $(export_symbols) \
        $(libgpgme_version_script_cmd) -version-info \