helpers: use print() in ChangeLog doctest for Python 3 compatibility
authorW. Trevor King <wking@tremily.us>
Mon, 12 Nov 2012 02:05:13 +0000 (21:05 -0500)
committerW. Trevor King <wking@tremily.us>
Mon, 12 Nov 2012 02:05:13 +0000 (21:05 -0500)
Also update the expected portage.latest.

pym/gentoolkit/helpers.py

index 90e0939af82f6627f603b28314aedc3b4499e968..706b5261318bbb38a6db00cd94648fcdeb44533b 100644 (file)
@@ -51,11 +51,12 @@ class ChangeLog(object):
        Example usage:
                >>> from gentoolkit.helpers import ChangeLog
                >>> portage = ChangeLog('/usr/portage/sys-apps/portage/ChangeLog')
-               >>> print portage.latest.strip()
-               *portage-2.2_rc50 (15 Nov 2009)
-
-                 15 Nov 2009; Zac Medico <zmedico@gentoo.org> +portage-2.2_rc50.ebuild:
-                 2.2_rc50 bump. This includes all fixes in 2.1.7.5.
+               >>> print(portage.latest.strip())
+               *portage-2.2.0_alpha142 (26 Oct 2012)
+               <BLANKLINE>
+                 26 Oct 2012; Zac Medico <zmedico@gentoo.org> +portage-2.2.0_alpha142.ebuild:
+                 2.2.0_alpha142 version bump. This includes all of the fixes in 2.1.11.31. Bug
+                 #210077 tracks all bugs fixed since portage-2.1.x.
                >>> len(portage.full)
                75
                >>> len(portage.entries_matching_range(