man page updates thanks to Francesco Turco. Update analyze and rebuild modules...
[gentoolkit.git] / setup.py
index 91f9e9c10817c5aeca5fe7bc8f662c35774835b6..1efba94d8d0b76b212bd4e6f427a5e06281056bc 100755 (executable)
--- a/setup.py
+++ b/setup.py
@@ -22,13 +22,13 @@ cwd = os.getcwd()
 try: 
        from portage.const import EPREFIX 
 except ImportError: 
-       EPREFIX='/
+       EPREFIX='' 
 
 
 # Bash files that need `VERSION=""` subbed, relative to this dir:
 bash_scripts = [os.path.join(cwd, path) for path in (
        'bin/euse',
-       'bin/revdep-rebuild'
+       'bin/revdep-rebuild.sh'
 )]
 
 # Python files that need `__version__ = ""` subbed, relative to this dir:
@@ -37,9 +37,10 @@ python_scripts = [os.path.join(cwd, path) for path in (
        'bin/epkginfo',
        'bin/glsa-check',
        'pym/gentoolkit/eclean/cli.py',
-       'pym/gentoolkit/analyse/__init__.py',
+       'pym/gentoolkit/enalyze/__init__.py',
        'pym/gentoolkit/equery/__init__.py',
-       'pym/gentoolkit/eshowkw/__init__.py'
+       'pym/gentoolkit/eshowkw/__init__.py',
+       'pym/gentoolkit/revdep_rebuild/__init__.py'
 )]
 
 
@@ -126,10 +127,10 @@ core.setup(
        package_data = test_data,
        scripts=(glob('bin/*')),
        data_files=(
-               (os.path.join(EPREFIX, 'etc/env.d'), ['data/99gentoolkit-env']),
-               (os.path.join(EPREFIX, 'etc/revdep-rebuild'), ['data/revdep-rebuild/99revdep-rebuild']),
-               (os.path.join(EPREFIX, 'etc/eclean'), glob('data/eclean/*')),
-               (os.path.join(EPREFIX, 'usr/share/man/man1'), glob('man/*')),
+               (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'etc/env.d'), ['data/99gentoolkit-env']),
+               (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'etc/revdep-rebuild'), ['data/revdep-rebuild/99revdep-rebuild']),
+               (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'etc/eclean'), glob('data/eclean/*')),
+               (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'usr/share/man/man1'), glob('man/*')),
        ),
        cmdclass={
                'test': load_test(),