eclean/test_clean: remove unused test_test_support import
[gentoolkit.git] / TODO
diff --git a/TODO b/TODO
index 859e8df5d1b06a2810c97994ff40fc9007ede67e..1cee1a429317ee83e9bfd4ec7d60db4fc266a990 100644 (file)
--- a/TODO
+++ b/TODO
@@ -3,15 +3,11 @@
  - add glsa pkgspec
   - query for current GLSAs on installed package(s)
 - rewrite ekeywords and echangelog to use gentoolkit
-- fully deprecate qpkg
-- fully deprecate pkg-size
 - merge change and echangelog
 - merge useflag and euse, have _one_ command line tool
   - update ufed to rely on the CLI tool
   - update ufed to rely on generate-use
   - merge generate-use and ufed?
-- rewrite revdep-rebuild to use gentoolkit
- - drop qpkg dependency; use equery instead
 - write efeatures for turning on/off FEATURES in make.conf
 - look at ekeys, ewatch
 - revision bump tool
  - use ~/.gentoo/gentoolkit/ebump.conf
  - use /etc/gentoolkit/ebump.conf
 
-equery:
-       Tests:
-               +helpers2 (FileOwner._extend_realpaths test probably doesn't clean up)
-       Run pylint and write test to run pylint
-       Write test to compile all modules (full syntax check). Take from portage.
+equery (modern):
        Add more --debug stuff
        Write tests for Dependencies._parser
-       Refactor each module to be useful for import. Done modules:
-               +depends
-               +belongs
-               +meta
-               +changes
-               +depgraph
+       Profile Dependencies._parser
+       Extend PackageFormatter usage to everything that outputs packages to
+         allow for purvasive use of -F, --format goodness
 
 Ebuild changes:
        - Add:
                src_test() {
                        "${python}" setup.py test || die "testing returned non zero"
                }
-       - Add:
-               DEPEND on python 2.5 (needed for 'from __future__ import with' and others)
 
 For Next Release:
        - write NEWS file
-       - write a docstring for Package which details especially the change in have
-         cpv as an object, not a string.