keyword: remove shebang from module without __name__ == '__main__' block
[gentoolkit.git] / README.dev
index 37864fb341b9eaee49aa2155e849bad18aaf7d99..951b707df77174cac4485eaff9b7c91b0b3ff0c2 100644 (file)
@@ -16,19 +16,18 @@ Note: We are using VERSION="0.3.0" simply as an example.
 
 - Run Gentoolkit's test suite, make sure it passes:
 Note: requires dev-python/snakeoil
-./setup.py test
 
-- Create a tag for the release
-svn copy svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/trunk/gentoolkit \
-         svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/tags/gentoolkit-0.3.0 \
-        -m "Tagging the <VERSION> release of gentoolkit."
-svn update to pull the tag from subversion
-cd to the local tags/gentoolkit-0.3.0 directory
+./setup.py test
 
-- Create a source distribution (you need to add VERSION here, too):
+- Create a source distribution (you need to add VERSION here):
 VERSION="0.3.0" ./setup.py sdist
 Transfer dist/gentoolkit-0.3.0.tar.gz to dev.gentoo.org:/space/distfiles-local
 
 - Clean up temporary files:
 ./setup.py clean -a
+git status
+rm or mv any untracked files/directories
 
+- Create a tag for the release
+git tag gentoolkit-0.3.0
+git push origin gentoolkit-0.3.0