www-misc/buku: Remove versions 3.{5,6,7}
[gentoo.git] / www-misc / buku / buku-3.5.ebuild
diff --git a/www-misc/buku/buku-3.5.ebuild b/www-misc/buku/buku-3.5.ebuild
deleted file mode 100644 (file)
index e563bc9..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Powerful command-line bookmark manager"
-HOMEPAGE="https://github.com/jarun/Buku"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-       dev-python/cryptography[${PYTHON_USEDEP}]
-       >=dev-python/urllib3-1.13.1[${PYTHON_USEDEP}]
-"
-
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/flake8[${PYTHON_USEDEP}]
-               dev-python/hypothesis[${PYTHON_USEDEP}]
-               dev-python/py[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-catchlog[${PYTHON_USEDEP}]
-       )
-"
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       insinto /usr/share/zsh/site-functions
-       doins auto-completion/zsh/_*
-
-       newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
-
-       doman buku.1
-}
-
-python_test() {
-       py.test -v tests/test_* || die
-}