net-nntp/suck: tidy 4.3.4 ebuild
[gentoo.git] / net-nntp / suck / suck-4.3.4.ebuild
index 6e3a5533c5c3438a200e819ef173169fb1b15a7b..ecb5006bebe9ccc87e7b5747e6911aa5a50d654c 100644 (file)
@@ -2,6 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+
 inherit autotools
 
 DESCRIPTION="Grab news from a remote NNTP server and feed them to another"
@@ -37,8 +38,13 @@ src_prepare() {
 }
 
 src_configure() {
-       use ssl || sed -i -e 's/^SSL_/#SSL_/' Makefile.in || die "ssl sed failed"
-       use perl || sed -i -e 's/^PERL_/#PERL_/' Makefile.in || die "perl sed failed"
+       if use ssl; then
+               sed -i -e 's/^SSL_/#SSL_/' Makefile.in || die "ssl sed failed"
+       fi
+
+       if use perl; then
+               sed -i -e 's/^PERL_/#PERL_/' Makefile.in || die "perl sed failed"
+       fi
 
        econf --without-inn-lib --without-inn-include
 }