media-sound/qjackctl: EAPI-7 bump, missing || die
[gentoo.git] / media-sound / qjackctl / qjackctl-9999.ebuild
index 87c768da8ec4416d969c71ce071210569947714e..3d91bddef6f41e146af496745bec750e4c6fe4c8 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit flag-o-matic qmake-utils autotools git-r3 xdg-utils
 
@@ -12,9 +12,9 @@ EGIT_REPO_URI="https://git.code.sf.net/p/qjackctl/code"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-
 IUSE="alsa dbus debug portaudio"
 
+BDEPEND="dev-qt/linguist-tools:5"
 RDEPEND="
        app-arch/gzip
        dev-qt/qtcore:5
@@ -26,24 +26,23 @@ RDEPEND="
        alsa? ( media-libs/alsa-lib )
        dbus? ( dev-qt/qtdbus:5 )
        portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}
-       dev-qt/linguist-tools:5"
+DEPEND="${RDEPEND}"
 
 src_prepare() {
-       eautoreconf
-
        default
+       eautoreconf
 }
 
 src_configure() {
        append-cxxflags -std=c++11
-       econf \
-               $(use_enable alsa alsa-seq) \
-               $(use_enable dbus) \
-               $(use_enable debug) \
-               $(use_enable portaudio) \
+       local myeconfargs=(
+               $(use_enable alsa alsa-seq)
+               $(use_enable dbus)
+               $(use_enable debug)
+               $(use_enable portaudio)
                --enable-jack-version
-
+       )
+       econf "${myeconfargs[@]}"
        eqmake5 ${PN}.pro -o ${PN}.mak
 }
 
@@ -54,8 +53,8 @@ src_compile() {
 src_install() {
        default
 
-       gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz"
-       gunzip "${D}/usr/share/man/man1/qjackctl.1.gz"
+       gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz" || die
+       gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
 }
 
 pkg_postinst() {