games-strategy/freeorion: Drop old
[gentoo.git] / games-strategy / freeorion / freeorion-9999.ebuild
index dba94bf60f98918ba93f462fda388ba34b0027d5..048d1b8bf695262442302ede2ed33252fff226b3 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
 inherit cmake-utils python-single-r1 xdg
 
 DESCRIPTION="A free turn-based space empire and galactic conquest game"
@@ -54,11 +54,6 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}"
 
-pkg_setup() {
-       # build system is using FindPythonLibs.cmake which needs python:2
-       python-single-r1_pkg_setup
-}
-
 src_prepare() {
        sed -e "s/-O3//" -i CMakeLists.txt || die