games-fps/gzdoom: Version bump to 4.3.1
[gentoo.git] / games-fps / gzdoom / gzdoom-4.3.1.ebuild
similarity index 67%
rename from games-fps/gzdoom/gzdoom-4.2.4.ebuild
rename to games-fps/gzdoom/gzdoom-4.3.1.ebuild
index f6844ab0cf13013aef9e8a99e999eada430d633b..1ba984d753b4939b2eb966fd0266885c76e560e8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -10,23 +10,24 @@ HOMEPAGE="https://zdoom.org"
 SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="BSD BZIP2 DUMB-0.9.3 GPL-3 LGPL-3 MIT
-       nonfree? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist )"
+       non-free? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist )"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86"
-IUSE="gtk gtk2 +nonfree openmp"
+IUSE="alsa fluidsynth gtk gtk2 mpg123 +non-free openmp sndfile"
 
 DEPEND="
        media-libs/libsdl2[opengl]
-       media-libs/libsndfile
        media-libs/openal
-       media-sound/fluidsynth:=
-       media-sound/mpg123
        sys-libs/zlib
        virtual/jpeg:0
+       alsa? ( media-libs/alsa-lib )
+       fluidsynth? ( media-sound/fluidsynth:= )
        gtk? (
                gtk2? ( x11-libs/gtk+:2 )
                !gtk2? ( x11-libs/gtk+:3 )
-       )"
+       )
+       mpg123? ( media-sound/mpg123 )
+       sndfile? ( media-libs/libsndfile )"
 RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${PN}-g${PV}"
@@ -38,7 +39,7 @@ PATCHES=(
 
 src_prepare() {
        rm -rf docs/licenses || die
-       if ! use nonfree ; then
+       if ! use non-free ; then
                rm -rf wadsrc_bm wadsrc_extra || die
        fi
 
@@ -57,7 +58,11 @@ src_configure() {
                -DNO_GTK="$(usex !gtk)"
                -DNO_OPENAL=OFF
                -DNO_OPENMP="$(usex !openmp)"
-               -DBUILD_NONFREE="$(usex nonfree)"
+               -DBUILD_NONFREE="$(usex non-free)"
+               -DCMAKE_DISABLE_FIND_PACKAGE_ALSA="$(usex !alsa)"
+               -DCMAKE_DISABLE_FIND_PACKAGE_FluidSynth="$(usex !fluidsynth)"
+               -DCMAKE_DISABLE_FIND_PACKAGE_MPG123="$(usex !mpg123)"
+               -DCMAKE_DISABLE_FIND_PACKAGE_SndFile="$(usex !sndfile)"
        )
        cmake_src_configure
 }
@@ -71,10 +76,10 @@ src_install() {
 pkg_postinst() {
        xdg_pkg_postinst
 
-       if ! use nonfree ; then
+       if ! use non-free ; then
                ewarn
-               ewarn "GZDoom installed without nonfree components."
-               ewarn "Note: The nonfree game_support.pk3 file is needed to play"
+               ewarn "GZDoom installed without non-free components."
+               ewarn "Note: The non-free game_support.pk3 file is needed to play"
                ewarn "      games natively supported by GZDoom."
                ewarn "A list of games natively supported by GZDoom is available"
                ewarn "on the ZDoom wiki: https://zdoom.org/wiki/IWAD"