sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / eclass / gnome2.eclass
index d64b31b73c6bfb4db97f61b7c0ce97578ce9d9ca..a16fc916c6d2b4d82a163ba0aab745002982dbc0 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 # @ECLASS: gnome2.eclass
 # @MAINTAINER:
 # gnome@gentoo.org
+# @SUPPORTED_EAPIS: 4 5 6
 # @BLURB: Provides phases for Gnome/Gtk+ based packages.
 # @DESCRIPTION:
 # Exports portage base functions used by ebuilds written for packages using the
 # Run eautoreconf instead of only elibtoolize
 GNOME2_EAUTORECONF=${GNOME2_EAUTORECONF:-""}
 
-if [[ ${GNOME2_EAUTORECONF} == 'yes' ]] ; then
-        AUTOTOOLS_AUTO_DEPEND=yes
-else
-        : ${AUTOTOOLS_AUTO_DEPEND:=no}
-fi
-
-inherit autotools eutils libtool gnome.org gnome2-utils xdg
+[[ ${GNOME2_EAUTORECONF} == 'yes' ]] && inherit autotools
+inherit eutils libtool ltprune gnome.org gnome2-utils xdg
 
 case "${EAPI:-0}" in
        4|5)
@@ -59,11 +54,11 @@ fi
 
 # @ECLASS-VARIABLE: GCONF_DEBUG
 # @DEFAULT_UNSET
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # Whether to handle debug or not.
 # Some gnome applications support various levels of debugging (yes, no, minimum,
-# etc), but using --disable-debug also removes g_assert which makes debugging   
-# harder. This variable should be set to yes for such packages for the eclass   
+# etc), but using --disable-debug also removes g_assert which makes debugging
+# harder. This variable should be set to yes for such packages for the eclass
 # to handle it properly. It will enable minimal debug with USE=-debug.
 # Note that this is most commonly found in configure.ac as GNOME_DEBUG_CHECK.
 #
@@ -74,7 +69,7 @@ if has ${EAPI:-0} 4 5; then
                IUSE="debug"
        fi
 fi
-    
+
 # @ECLASS-VARIABLE: GNOME2_ECLASS_GIO_MODULES
 # @INTERNAL
 # @DESCRIPTION:
@@ -321,7 +316,6 @@ gnome2_src_install() {
 gnome2_pkg_preinst() {
        xdg_pkg_preinst
        gnome2_gconf_savelist
-       gnome2_icon_savelist
        gnome2_schemas_savelist
        gnome2_scrollkeeper_savelist
        gnome2_gdk_pixbuf_savelist
@@ -343,8 +337,9 @@ gnome2_pkg_preinst() {
 gnome2_pkg_postinst() {
        xdg_pkg_postinst
        gnome2_gconf_install
-       gnome2_icon_cache_update
-       gnome2_schemas_update
+       if [[ -n ${GNOME2_ECLASS_GLIB_SCHEMAS} ]]; then
+               gnome2_schemas_update
+       fi
        gnome2_scrollkeeper_update
        gnome2_gdk_pixbuf_update
 
@@ -363,8 +358,9 @@ gnome2_pkg_postinst() {
 # Handle scrollkeeper, GSettings, Icons, desktop and mime database updates.
 gnome2_pkg_postrm() {
        xdg_pkg_postrm
-       gnome2_icon_cache_update
-       gnome2_schemas_update
+       if [[ -n ${GNOME2_ECLASS_GLIB_SCHEMAS} ]]; then
+               gnome2_schemas_update
+       fi
        gnome2_scrollkeeper_update
 
        if [[ ${#GNOME2_ECLASS_GIO_MODULES[@]} -gt 0 ]]; then