From: Mart Raudsepp <leio@gentoo.org>
Date: Sun, 1 Mar 2020 08:26:20 +0000 (+0200)
Subject: app-misc/bijiben: bump to 3.34.2
X-Git-Url: http://git.tremily.us/?a=commitdiff_plain;h=ec655d79567693431cca908ae33dceea859aff03;p=gentoo.git

app-misc/bijiben: bump to 3.34.2

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
---

diff --git a/app-misc/bijiben/Manifest b/app-misc/bijiben/Manifest
index 48428be5834a..ca0126174d0e 100644
--- a/app-misc/bijiben/Manifest
+++ b/app-misc/bijiben/Manifest
@@ -1 +1,2 @@
 DIST bijiben-3.32.2.tar.xz 659988 BLAKE2B a155b3ad4d340b6efe039ae8458be6665f5ea37935b2040d8aa59f4b019a7ce2a9bb42c309fbc212b8f87cd2e3db533305b64d6987b3b527435ab9906165a7ff SHA512 71573ced01a5e984998fc5ce97ebbd4fcf04a91165465697ff29ea67076a31654b8f66a93c3ed79b30a8af2e38fad3ac4bfc3047106411078c6cbb67c20d5c5d
+DIST bijiben-3.34.2.tar.xz 663348 BLAKE2B 7736823334c5439f1da93e81940f6a433b48cf94173606b1985912b408ebaa05d14866b0bbdd0978c08456fe5a592829203aa7fdd31291748148d7973ab3d8ab SHA512 75e1286aabd5c0d5aca3d2150aa36f18873cc0bfeed24a1b6aa9f4d78318d37712df71929f453b2db871021f4df148af8a9ef64d563a2158db8c1dbb620e4538
diff --git a/app-misc/bijiben/bijiben-3.34.2.ebuild b/app-misc/bijiben/bijiben-3.34.2.ebuild
new file mode 100644
index 000000000000..f83923e7b5fd
--- /dev/null
+++ b/app-misc/bijiben/bijiben-3.34.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Note editor designed to remain simple to use"
+HOMEPAGE="https://wiki.gnome.org/Apps/Notes"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+	app-misc/tracker:0/2.0
+	>=dev-libs/glib-2.53.4:2
+	net-libs/gnome-online-accounts:=
+	>=x11-libs/gtk+-3.19.3:3
+	>=gnome-extra/evolution-data-server-3.33.2:=
+	dev-libs/libxml2:2
+	sys-apps/util-linux
+	>=net-libs/webkit-gtk-2.10:4
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+	dev-libs/appstream-glib
+	dev-util/gdbus-codegen
+	dev-util/glib-utils
+	dev-util/itstool
+	>=sys-devel/gettext-0.19.8
+	virtual/pkgconfig
+"
+
+src_configure() {
+	local emesonargs=(
+		-Dzeitgeist=false
+		-Dupdate_mimedb=false
+		-Dprivate_store=false # private store is mainly meant for flatpak builds
+	)
+	meson_src_configure
+}
+
+pkg_postinst() {
+	xdg_pkg_postinst
+	gnome2_schemas_update
+}
+
+pkg_postrm() {
+	xdg_pkg_postrm
+	gnome2_schemas_update
+}