From: Matt Turner <mattst88@gentoo.org>
Date: Thu, 6 Jun 2019 00:14:34 +0000 (-0700)
Subject: dev-libs/libevdev: Version bump to 1.7.0
X-Git-Url: http://git.tremily.us/?a=commitdiff_plain;h=ccf08d54c43e5bef81f316866800fe64153ecb5a;p=gentoo.git

dev-libs/libevdev: Version bump to 1.7.0

Signed-off-by: Matt Turner <mattst88@gentoo.org>
---

diff --git a/dev-libs/libevdev/Manifest b/dev-libs/libevdev/Manifest
index 7b4b434b230c..302912964e40 100644
--- a/dev-libs/libevdev/Manifest
+++ b/dev-libs/libevdev/Manifest
@@ -1 +1,2 @@
 DIST libevdev-1.6.0.tar.xz 411512 BLAKE2B 0e9190fd4c28b36bcf325953aa634c0d8c604cef7f56e46679fc88351536d78b0bddedbbdfffe4164e0039c7d56ef604b143e23de2c4bb9a66653a03d6844fa9 SHA512 73046da447773716c9f0c9f511f3a0a6ababcf92a146eba363014afcbdb465f4c3cd8be0917f2f01561a72f24f20fe8ecd333467437d9d85c03afcb433d05060
+DIST libevdev-1.7.0.tar.xz 438264 BLAKE2B 3f71ccdfbd68598afed7316dd4902a8ac439c6f094788abed5cb8ed24acaf070edaeceefad17de51cadb039259aa0de6a8ec576fa1f8dbd60878ee75aeb39fde SHA512 bc43723fd1ca251a77ee549022609f73c15a33ae470fc843ac687542fb1938fba4d046d3ee1dc814bc38a4292a7f2ad9e71fcce45525b518a4f4a5bef099aa6f
diff --git a/dev-libs/libevdev/libevdev-1.7.0.ebuild b/dev-libs/libevdev/libevdev-1.7.0.ebuild
new file mode 100644
index 000000000000..c32b139bc873
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit multilib-minimal python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
+
+if [[ ${PV} == 9999* ]] ; then
+	EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
+	inherit autotools git-r3
+else
+	SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+	KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc static-libs"
+
+BDEPEND="
+	${PYTHON_DEPS}
+	doc? ( app-doc/doxygen )
+	virtual/pkgconfig
+"
+RESTRICT="test" # Tests need to run as root.
+
+src_prepare() {
+	default
+	[[ ${PV} == 9999* ]] && eautoreconf
+}
+
+multilib_src_configure() {
+	ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+	default
+	find "${D}" -name '*.la' -delete || die
+	if use doc ;then
+		local HTML_DOCS=( doc/html/. )
+		einstalldocs
+	fi
+}