From: Zac Medico <zmedico@gentoo.org>
Date: Sun, 19 Aug 2018 23:05:36 +0000 (-0700)
Subject: dev-go/go-text: update 9999 ebuild
X-Git-Url: http://git.tremily.us/?a=commitdiff_plain;h=8879bac8a4cce89f6a5583ed8076e0ae770e71c6;p=gentoo.git

dev-go/go-text: update 9999 ebuild

Package-Manager: Portage-2.3.47, Repoman-2.3.10
---

diff --git a/dev-go/go-text/go-text-9999.ebuild b/dev-go/go-text/go-text-9999.ebuild
index 5768c80ac6f4..4d851787c267 100644
--- a/dev-go/go-text/go-text-9999.ebuild
+++ b/dev-go/go-text/go-text-9999.ebuild
@@ -1,16 +1,16 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-EGO_PN=golang.org/x/text/...
 EGO_SRC=golang.org/x/text
+EGO_PN=${EGO_SRC}/...
 
 if [[ ${PV} = *9999* ]]; then
 	inherit golang-vcs
 else
-	KEYWORDS="~amd64"
-	EGIT_COMMIT="df923bbb63f8ea3a26bb743e2a497abd0ab585f7"
+	KEYWORDS="~amd64 ~arm ~x86"
+	EGIT_COMMIT="v${PV}"
 	SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
 	inherit golang-vcs-snapshot
 fi
@@ -21,28 +21,28 @@ HOMEPAGE="https://godoc.org/golang.org/x/text"
 LICENSE="BSD"
 SLOT="0/${PVR}"
 IUSE=""
-DEPEND=""
+DEPEND=">=dev-go/go-tools-0_pre20180817"
 RDEPEND=""
 
-src_test() {
-	# Create a writable GOROOT in order to avoid sandbox violations.
-	cp -sR "$(go env GOROOT)" "${T}/goroot" || die
-	if [ -d "${T}/goroot/src/${EGO_SRC}" ]; then
-		rm -rf "${T}/goroot/src/${EGO_SRC}" || die
-	fi
-	if [ -d "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" ]; then
-		rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" ||
-			die
-	fi
-
-	# Create go symlink for TestLinking in display/dict_test.go
-	mkdir -p "${T}/goroot/bin"
-	ln -s /usr/bin/go  "${T}/goroot/bin/go" || die
-
-	GOROOT="${T}/goroot" golang-build_src_test
+src_compile() {
+	# Create an isolated golibdir in order to avoid an
+	# "use of internal package not allowed" error when
+	# and older version is installed.
+	mkdir -p "${T}/golibdir/src/golang.org/x" || die
+	ln -s "$(get_golibdir_gopath)/src/golang.org/x/tools" "${T}/golibdir/src/golang.org/x/tools" || die
+	GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
+		go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
 }
 
 src_install() {
-	golang-build_src_install
-	dobin bin/*
+	rm -rf "${S}/src/${EGO_SRC}/.git"* || die
+	golang_install_pkgs
+	exeopts -m0755 -p # preserve timestamps for bug 551486
+	exeinto "$(go env GOROOT)/bin"
+	doexe bin/*
+}
+
+src_test() {
+	GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
+		go test -v -work -x "${EGO_PN}" || die
 }