From: Michał Górny <mgorny@gentoo.org>
Date: Mon, 2 Mar 2020 05:47:04 +0000 (+0100)
Subject: dev-python/hypothesis: Bump to 5.6.0
X-Git-Url: http://git.tremily.us/?a=commitdiff_plain;h=346e9091f631291a580e8d4d1ae3d9d979f841a7;p=gentoo.git

dev-python/hypothesis: Bump to 5.6.0

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---

diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 255e87964011..6eda1b1aac2c 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -6,3 +6,4 @@ DIST hypothesis-python-5.5.0.tar.gz 8996266 BLAKE2B c9eebe4bf1df5cbf7a40dabeecc9
 DIST hypothesis-python-5.5.1.tar.gz 8996186 BLAKE2B 0e1e013b0339e504603b583882f6d05efa96e5b97b02967c49001c329923df7b2b2666a5351f223ab991cc86f6b0b7ae91c3f6e34c1e089a9f06a271dc7b887f SHA512 4129d85a0e4d2614cd2d8d018043b6346d59f973cce79cdbab2d8688d1c18e9dd0b9044515d715c80e03812020f134a8897931a9942eaad181567750a7cee049
 DIST hypothesis-python-5.5.2.tar.gz 8996253 BLAKE2B eccdbae595e3242b6e0f8d5b363aa4b23f279959bf87e801885be2f072ea8cafa39ec1122695f26a333ee99a191cf17342d95b74a4d216e06fecda53ab47d96f SHA512 e2be0bfd07e0e192e104b827616f822c1a4e87f7691a6b754a623d8ec268851f769ff9a0bf64c424cf583b5d87e4040df92ec203eac1b41034b4d24d5ea1d1d2
 DIST hypothesis-python-5.5.4.tar.gz 8997160 BLAKE2B ef85a521a9572afd4fa3d682722bddca04f6e5a5cb4283e05099148b374a635e1ad67d4b72b8baf752d33d4b9967464d28c5e293113af1a2218928352ffb2e15 SHA512 fa1946722a8fa3bb90ec0fa0786b03da11514779d5598d549c98a17217ce6e848603904de06b5f8a24321adbfa7b3c6e0d79e63d158c633619572623243deb13
+DIST hypothesis-python-5.6.0.tar.gz 8997446 BLAKE2B 245c9219ae5642f74813d7c218cfec44065c6febcbc89811f0cee08261e35ae50ef56e9779b2a7434bea88b5764721ef7752cf198b846f08e15c8dfe647d7640 SHA512 40fe07f6f19d667a961d4ace7febe0c5476922c8929f0b7f77af52229e6d667a1a1b2d40c91e2ea18d9919288821508e598afcdb4b5edb71f03084e43d1eaa4b
diff --git a/dev-python/hypothesis/hypothesis-5.6.0.ebuild b/dev-python/hypothesis/hypothesis-5.6.0.ebuild
new file mode 100644
index 000000000000..b3200160cc3e
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+	>=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+	>=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+	test? (
+		${RDEPEND}
+		dev-python/mock[${PYTHON_USEDEP}]
+		dev-python/pexpect[${PYTHON_USEDEP}]
+		>=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+		!!<dev-python/typing-3.7.4.1
+	)
+"
+
+src_prepare() {
+	# avoid pytest-xdist dep for one test
+	sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+		tests/pytest/test_statistics.py || die
+	distutils-r1_src_prepare
+}
+
+python_test() {
+	pytest -vv tests/cover tests/pytest tests/quality ||
+		die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+	optfeature "datetime support" dev-python/pytz
+	optfeature "dateutil support" dev-python/python-dateutil
+	optfeature "numpy support" dev-python/numpy
+	optfeature "django support" dev-python/django dev-python/pytz
+	optfeature "pandas support" dev-python/pandas
+	optfeature "pytest support" dev-python/pytest
+}