sci-chemistry/pymol: Remove old (drop to ~arch)
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 16:48:52 +0000 (17:48 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 18:24:07 +0000 (19:24 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sci-chemistry/pymol/Manifest
sci-chemistry/pymol/pymol-1.8.4.0-r2.ebuild [deleted file]

index ab400768a37f819545681099ee7ca983cfc1d9d7..5204b446eb88860ef9ad9a0d7636469dda3fd007 100644 (file)
@@ -1,3 +1,2 @@
 DIST pymol-1.8.4.0.png.xz 19528 BLAKE2B f3d23d4cedca3d8bb96b20646a548da4be570697e3346a11b01c5c3599b536ba4697be08472dfa8a4f6533167defc1a37a1de332931a73857319cb28fd42cd2b SHA512 40bb0d3f226476f6e047b5361956aad955232a97641474765eaa5204f0539aee3810e0266213618a45364f9f31f6eb18380b17e0c79f64065f7b62a9016caa7c
 DIST pymol-2.3.0.tar.gz 10448674 BLAKE2B 0d508587d880ce7f2e8a0481bf664e6bfe6eb1d68b0f48b9266cde756824bd8c0144d7243e958bbc5e571d60fca9dafff125d81a8a3d32107e78ad2ff8dffc05 SHA512 e1dcea1c97bcd9045d3543e92902f240e6affbf61a38e8d2a0be04309e3dbabfe1a869847d1423b3151008978d4c305bbf3ce994fc9d453c0063ce020100c133
-DIST pymol-v1.8.4.0.tar.bz2 8717344 BLAKE2B a4cfb95eb40a3cd3da5b8cfd4acac7255997f9a3e49ef7e7e1d4c13f36e4aace462a054c326bbaadbc99f22286be878a6d5c518149760b5c939ce9362d4b8cc3 SHA512 73a810adfc31adaf0f3fa25512084882c87b0782c8af716ac0203a5b5b7f0b9fedfbce3d129bffef7b52044e92b0542e683966b2acf961c4dac17fbba72dd7fe
diff --git a/sci-chemistry/pymol/pymol-1.8.4.0-r2.ebuild b/sci-chemistry/pymol/pymol-1.8.4.0-r2.ebuild
deleted file mode 100644 (file)
index f60de8d..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="tk"
-
-inherit distutils-r1 eutils fdo-mime flag-o-matic versionator
-
-DESCRIPTION="A Python-extensible molecular graphics system"
-HOMEPAGE="https://www.pymol.org/"
-SRC_URI="
-       https://dev.gentoo.org/~jlec/distfiles/${P}.png.xz
-       mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-2)/${PN}-v${PV}.tar.bz2
-       "
-# git archive -v --prefix=${P}/ master -o ${P}.tar.xz
-RESTRICT="mirror"
-LICENSE="PSF-2.2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="web"
-
-DEPEND="
-       || (
-               dev-python/numpy-python2[${PYTHON_USEDEP}]
-               dev-python/numpy[${PYTHON_USEDEP}]
-       )
-       dev-python/pmw:py2[${PYTHON_USEDEP}]
-       dev-python/pyopengl[${PYTHON_USEDEP}]
-       media-libs/freeglut
-       media-libs/freetype:2
-       media-libs/glew:0=
-       media-libs/libpng:0=
-       media-video/mpeg-tools
-       sys-libs/zlib
-       !sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
-       web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${PN}
-
-python_prepare_all() {
-       sed \
-               -e "s:\"/usr:\"${EPREFIX}/usr:g" \
-               -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
-               -e "/import/s:argparse:argparseX:g" \
-               -i setup.py || die
-
-       sed \
-               -e "s:/opt/local:${EPREFIX}/usr:g" \
-               -e '/ext_comp_args/s:\[.*\]:[]:g' \
-               -i setup.py || die
-
-       append-cxxflags -std=c++0x
-
-       distutils-r1_python_prepare_all
-}
-
-python_install() {
-       distutils-r1_python_install --pymol-path="${EPREFIX}/usr/share/pymol"
-
-       sed \
-               -e '1d' \
-               -e "/APBS_BINARY_LOCATION/s:None:\"${EPREFIX}/usr/bin/apbs\":g" \
-               -e "/APBS_PSIZE_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/src/\":g" \
-               -e "/APBS_PDB2PQR_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/\":g" \
-               -i "${D}/$(python_get_sitedir)"/pmg_tk/startup/apbs_tools.py || die
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       sed \
-               -e '1i#!/usr/bin/env python' \
-               "${D}/$(python_get_sitedir)"/pymol/__init__.py > "${T}"/${PN} || die
-
-       python_foreach_impl python_doscript "${T}"/${PN}
-
-       # These environment variables should not go in the wrapper script, or else
-       # it will be impossible to use the PyMOL libraries from Python.
-       cat >> "${T}"/20pymol <<- EOF
-               PYMOL_PATH="${EPREFIX}/usr/share/pymol"
-               PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
-               PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
-       EOF
-
-       doenvd "${T}"/20pymol
-
-       newicon "${WORKDIR}"/${P}.png ${PN}.png
-       make_desktop_entry ${PN} PyMol ${PN} \
-               "Graphics;Education;Science;Chemistry;" \
-               "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
-
-       if ! use web; then
-               rm -rf "${D}/$(python_get_sitedir)/web" || die
-       fi
-
-       rm -f "${ED}"/usr/share/${PN}/LICENSE || die
-}
-
-pkg_postinst() {
-       fdo-mime_desktop_database_update
-       fdo-mime_mime_database_update
-       optfeature "Electrostatic calculations" sci-chemistry/apbs sci-chemistry/pdb2pqr
-}
-
-pkg_postrm() {
-       fdo-mime_desktop_database_update
-       fdo-mime_mime_database_update
-}