media-libs/sdl2-mixer: version bump
authorMichael Sterrett <mr_bones_@gentoo.org>
Sun, 3 Jan 2016 18:15:52 +0000 (13:15 -0500)
committerMichael Sterrett <mr_bones_@gentoo.org>
Sun, 3 Jan 2016 18:15:52 +0000 (13:15 -0500)
Package-Manager: portage-2.2.24

media-libs/sdl2-mixer/Manifest
media-libs/sdl2-mixer/sdl2-mixer-2.0.1.ebuild [new file with mode: 0644]

index d9021f3f10cda764460e3df8eb640adf60549bf9..d765ce3a67fc787b056982e66e84dad994375a64 100644 (file)
@@ -1 +1,2 @@
 DIST SDL2_mixer-2.0.0.tar.gz 10119589 SHA256 a8ce0e161793791adeff258ca6214267fdd41b3c073d2581cd5265c8646f725b SHA512 e04594abc13c2b6527cd92a94a8d3e18436e9e6aaee21bab83e288e259a2fb20aae8433765d07feeb3b5bf253951323d67054239091e79720846770beb30be4d WHIRLPOOL 58385d7bdb3382af4f9d3aa9904b40083fe1139af0c938fa807904d70d4561180f65314bb2ab56f3b67a35140252e72802753ed723bca2536a4745fad43cb905
+DIST SDL2_mixer-2.0.1.tar.gz 10213891 SHA256 5a24f62a610249d744cbd8d28ee399d8905db7222bf3bdbc8a8b4a76e597695f SHA512 bdf2b4fc302f9c3b41d40bfdd5132081439e6021e915f191e478235b7b6565e7b4c43e1172d2055066ad505e2bc70876123c58f5a67218b207c829ee66a84b9d WHIRLPOOL b9ebeaad35ed92e8de111872d17ceefdc996ebbbb91f3b35fa9ab62573fae972e1a1626cc86141260c69af87a53a0880230ec399fe06fa3c5a98b20d82be8515
diff --git a/media-libs/sdl2-mixer/sdl2-mixer-2.0.1.ebuild b/media-libs/sdl2-mixer/sdl2-mixer-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..14879cc
--- /dev/null
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib-minimal
+
+MY_P=SDL2_mixer-${PV}
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac fluidsynth mad midi mikmod mod modplug mp3 playtools smpeg static-libs timidity tremor vorbis +wav"
+REQUIRED_USE="
+       midi? ( || ( timidity fluidsynth ) )
+       timidity? ( midi )
+       fluidsynth? ( midi )
+       mp3? ( || ( smpeg mad ) )
+       smpeg? ( mp3 )
+       mad? ( mp3 )
+       mod? ( || ( mikmod modplug ) )
+       mikmod? ( mod )
+       modplug? ( mod )
+       tremor? ( vorbis )
+       "
+
+RDEPEND=">=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]
+       flac? ( >=media-libs/flac-1.2.1-r5[${MULTILIB_USEDEP}] )
+       midi? (
+               fluidsynth? ( >=media-sound/fluidsynth-1.1.6-r1[${MULTILIB_USEDEP}] )
+               timidity? ( media-sound/timidity++ )
+       )
+       mp3? (
+               mad? ( >=media-libs/libmad-0.15.1b-r8[${MULTILIB_USEDEP}] )
+               smpeg? ( >=media-libs/smpeg2-2.0.0-r1[${MULTILIB_USEDEP}] )
+       )
+       mod? (
+               modplug? ( >=media-libs/libmodplug-0.8.8.4-r1[${MULTILIB_USEDEP}] )
+               mikmod? ( >=media-libs/libmikmod-3.3.6-r1[${MULTILIB_USEDEP}] )
+       )
+       vorbis? (
+               tremor? ( >=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}] )
+               !tremor? (
+                       >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
+                       >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
+       )"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} \
+       econf \
+               $(use_enable static-libs static) \
+               --disable-sdltest \
+               --enable-music-cmd \
+               $(use_enable wav music-wave) \
+               $(use_enable mod music-mod) \
+               $(use_enable modplug music-mod-modplug) \
+               --disable-music-mod-modplug-shared \
+               $(use_enable mikmod music-mod-mikmod) \
+               --disable-music-mod-mikmod-shared \
+               $(use_enable midi music-midi) \
+               $(use_enable timidity music-midi-timidity) \
+               $(use_enable fluidsynth music-midi-fluidsynth) \
+               --disable-music-midi-fluidsynth-shared \
+               $(use_enable vorbis music-ogg) \
+               $(use_enable tremor music-ogg-tremor) \
+               --disable-music-ogg-shared \
+               $(use_enable flac music-flac) \
+               --disable-music-flac-shared \
+               $(use_enable mp3 music-mp3) \
+               $(use_enable smpeg music-mp3-smpeg) \
+               --disable-music-mp3-smpeg-shared \
+               --disable-smpegtest \
+               $(use_enable mad music-mp3-mad-gpl) \
+               LIBMIKMOD_CONFIG=${EPREFIX}/usr/bin/${CHOST}-libmikmod-config
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" install
+       if multilib_is_native_abi && use playtools; then
+               emake DESTDIR="${D}" install-bin
+       fi
+}
+
+multilib_src_install_all() {
+       dodoc {CHANGES,README}.txt
+       prune_libtool_files
+}
+
+pkg_postinst() {
+       # bug 412035
+       # https://bugs.gentoo.org/show_bug.cgi?id=412035
+       if use midi ; then
+               if use fluidsynth; then
+                       ewarn "FluidSynth support requires you to set the SDL_SOUNDFONTS"
+                       ewarn "environment variable to the location of a SoundFont file"
+                       ewarn "unless the game or application happens to do this for you."
+
+                       if use timidity; then
+                               ewarn "Failing to do so will result in Timidity being used instead."
+                       else
+                               ewarn "Failing to do so will result in silence."
+                       fi
+               fi
+       fi
+}