www-client/chromium: dev channel bump to 82.0.4083.0
authorStephan Hartmann <stha09@googlemail.com>
Sun, 15 Mar 2020 15:54:02 +0000 (16:54 +0100)
committerMike Gilbert <floppym@gentoo.org>
Sun, 15 Mar 2020 18:35:15 +0000 (14:35 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/14966

www-client/chromium/Manifest
www-client/chromium/chromium-82.0.4083.0.ebuild [moved from www-client/chromium/chromium-82.0.4077.0.ebuild with 99% similarity]
www-client/chromium/files/chromium-82-gcc-iterator.patch [new file with mode: 0644]
www-client/chromium/files/chromium-compiler-r12.patch

index a4707f6e53f687ea6fd4aff80a0cafde4efc68c2..b0fbf7e447002cf1dec09e9236a34110dc9e838c 100644 (file)
@@ -1,3 +1,3 @@
 DIST chromium-80.0.3987.132.tar.xz 796975056 BLAKE2B 0da35d3218f4f44c15f05693336a034876764ef228f173cd00cedc045ebc06972416779a39458863b47a1863ab8f21b5d2dc11c6ed33ee81649cd0316bf31524 SHA512 10bf0d1efdf2ead9e94de90971ec135f5370f8c949acfd75ca953aed706510cc3a1464f1ff3c40275921bb24953d8ce65d095e38cb0d56488ccc2c7fa27516d4
 DIST chromium-81.0.4044.62.tar.xz 785977660 BLAKE2B a9346e9e5761a1210cae245d955dce9ec807a21e3343de11e52581d161eaf8170876c4eb7f145453bf3736b54006b9142b09be834cb1fd7702a078f3ec0a2617 SHA512 f6728e2b8f81ccab0ffecc511a2364badba9f1d2149dc209de0c5f824108085afef4459f9e0bfbe571acd363405a8d77e80ea59150c4f9783717aa2f68f060e2
-DIST chromium-82.0.4077.0.tar.xz 793873940 BLAKE2B 9629ca475e135e68bf99bfae5566b49c1516b2abc78f1bdfc9cb2135802c994b4bfc3860d12797abc1c89fa478ab7aa9fdb60af2f5d080cb00093a5fb42d064d SHA512 b0b039f663257617e62e5620fd19272871f3bbe33b19a6adb23882fa7bccf358d3c09495caf96e37e2670321000ecf685588df8566451364931c6a3418eca91b
+DIST chromium-82.0.4083.0.tar.xz 794521032 BLAKE2B 5437aaed6c81bab1bd6495db0665fe6c3fbd1058535272d19a6d6c9d34db0102ff3464e1f210461c0944dd84257bc036004aed412f91590a6ff951c1e3fb7925 SHA512 412757cd004ceb7946bd4b8f30afd9589f6b33595a9f231c4a43a7a6328547fec8bdf42d751ec4babc244c16d7b9bbd2448adeb155e4ac354d714180a69c0709
similarity index 99%
rename from www-client/chromium/chromium-82.0.4077.0.ebuild
rename to www-client/chromium/chromium-82.0.4083.0.ebuild
index 019d9968c0e0224f6ba60d04f31fa4adf4b1d10d..e93d8f46ddbd6744542606f5e2b543f20e8e92e6 100644 (file)
@@ -94,7 +94,7 @@ BDEPEND="
                dev-lang/yasm
        )
        dev-lang/perl
-       dev-util/gn
+       >=dev-util/gn-0.1726
        dev-vcs/git
        >=dev-util/gperf-3.0.3
        >=dev-util/ninja-1.7.2
@@ -148,6 +148,7 @@ PATCHES=(
        "${FILESDIR}/chromium-82-gcc-noexcept.patch"
        "${FILESDIR}/chromium-82-gcc-incomplete-type.patch"
        "${FILESDIR}/chromium-82-gcc-template.patch"
+       "${FILESDIR}/chromium-82-gcc-iterator.patch"
        "${FILESDIR}/chromium-82-clang-std.patch"
 )
 
diff --git a/www-client/chromium/files/chromium-82-gcc-iterator.patch b/www-client/chromium/files/chromium-82-gcc-iterator.patch
new file mode 100644 (file)
index 0000000..6405d52
--- /dev/null
@@ -0,0 +1,23 @@
+diff --git a/third_party/blink/renderer/core/layout/ng/ng_physical_container_fragment.h b/third_party/blink/renderer/core/layout/ng/ng_physical_container_fragment.h
+index b3c7624..85936aa 100644
+--- a/third_party/blink/renderer/core/layout/ng/ng_physical_container_fragment.h
++++ b/third_party/blink/renderer/core/layout/ng/ng_physical_container_fragment.h
+@@ -5,6 +5,8 @@
+ #ifndef THIRD_PARTY_BLINK_RENDERER_CORE_LAYOUT_NG_NG_PHYSICAL_CONTAINER_FRAGMENT_H_
+ #define THIRD_PARTY_BLINK_RENDERER_CORE_LAYOUT_NG_NG_PHYSICAL_CONTAINER_FRAGMENT_H_
++#include <iterator>
++
+ #include "base/containers/span.h"
+ #include "third_party/blink/renderer/core/core_export.h"
+ #include "third_party/blink/renderer/core/layout/geometry/physical_rect.h"
+@@ -31,7 +33,8 @@ class CORE_EXPORT NGPhysicalContainerFragment : public NGPhysicalFragment {
+     PostLayoutChildLinkList(wtf_size_t count, const NGLink* buffer)
+         : count_(count), buffer_(buffer) {}
+-    class ConstIterator {
++    class ConstIterator : public std::iterator<std::input_iterator_tag,
++                                               NGLink> {
+       STACK_ALLOCATED();
+      public:
index 3d8117e4c0651feb1bd759015a693b02f9f28fe1..840059b4f57df853ff79235ec9ab3883c19552e0 100644 (file)
@@ -1,6 +1,6 @@
-From 2e9a5f0e54d8968c4fab8f1cd00c225e387f0187 Mon Sep 17 00:00:00 2001
+From c2a95e376474298b01cb04f1d5b2c6e3c76ba268 Mon Sep 17 00:00:00 2001
 From: Mike Gilbert <floppym@gentoo.org>
-Date: Fri, 6 Mar 2020 17:10:30 +0000
+Date: Fri, 13 Mar 2020 20:20:06 +0000
 Subject: [PATCH] Disable various compiler configs
 
 ---
@@ -8,7 +8,7 @@ Subject: [PATCH] Disable various compiler configs
  1 file changed, 23 insertions(+), 44 deletions(-)
 
 diff --git a/build/config/compiler/BUILD.gn b/build/config/compiler/BUILD.gn
-index d4597c7..4c651ac 100644
+index 8f7fcc3..d27e71e 100644
 --- a/build/config/compiler/BUILD.gn
 +++ b/build/config/compiler/BUILD.gn
 @@ -261,8 +261,6 @@ config("compiler") {
@@ -47,7 +47,7 @@ index d4597c7..4c651ac 100644
    # C11/C++11 compiler flags setup.
    # ---------------------------
    if (is_linux || is_android || (is_nacl && is_clang) || current_os == "aix") {
-@@ -1442,6 +1420,12 @@ config("default_warnings") {
+@@ -1437,6 +1415,12 @@ config("default_warnings") {
          cflags_cc += [ "-Wno-class-memaccess" ]
        }
  
@@ -60,7 +60,7 @@ index d4597c7..4c651ac 100644
        # -Wunused-local-typedefs is broken in gcc,
        # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63872
        cflags += [ "-Wno-unused-local-typedefs" ]
-@@ -1563,7 +1547,7 @@ config("chromium_code") {
+@@ -1558,7 +1542,7 @@ config("chromium_code") {
        defines = [ "_HAS_NODISCARD" ]
      }
    } else {
@@ -69,7 +69,7 @@ index d4597c7..4c651ac 100644
      if (treat_warnings_as_errors) {
        cflags += [ "-Werror" ]
  
-@@ -1572,10 +1556,6 @@ config("chromium_code") {
+@@ -1567,10 +1551,6 @@ config("chromium_code") {
        # well.
        ldflags = [ "-Werror" ]
      }
@@ -80,7 +80,7 @@ index d4597c7..4c651ac 100644
  
      # In Chromium code, we define __STDC_foo_MACROS in order to get the
      # C99 macros on Mac and Linux.
-@@ -1584,15 +1564,6 @@ config("chromium_code") {
+@@ -1579,15 +1559,6 @@ config("chromium_code") {
        "__STDC_FORMAT_MACROS",
      ]
  
@@ -96,7 +96,7 @@ index d4597c7..4c651ac 100644
      if (is_mac) {
        cflags_objc = [ "-Wobjc-missing-property-synthesis" ]
        cflags_objcc = [ "-Wobjc-missing-property-synthesis" ]
-@@ -1984,7 +1955,8 @@ config("default_stack_frames") {
+@@ -1979,7 +1950,8 @@ config("default_stack_frames") {
  }
  
  # Default "optimization on" config.
@@ -106,7 +106,7 @@ index d4597c7..4c651ac 100644
    if (is_win) {
      # Favor size over speed, /O1 must be before the common flags.
      # /O1 implies /Os and /GF.
-@@ -2005,7 +1977,8 @@ config("optimize") {
+@@ -2000,7 +1972,8 @@ config("optimize") {
  }
  
  # Turn off optimizations.
@@ -116,7 +116,7 @@ index d4597c7..4c651ac 100644
    if (is_win) {
      cflags = [
        "/Od",  # Disable optimization.
-@@ -2039,7 +2012,8 @@ config("no_optimize") {
+@@ -2034,7 +2007,8 @@ config("no_optimize") {
  # Turns up the optimization level. On Windows, this implies whole program
  # optimization and link-time code generation which is very expensive and should
  # be used sparingly.
@@ -126,7 +126,7 @@ index d4597c7..4c651ac 100644
    if (is_nacl && is_nacl_irt) {
      # The NaCl IRT is a special case and always wants its own config.
      # Various components do:
-@@ -2071,7 +2045,8 @@ config("optimize_max") {
+@@ -2066,7 +2040,8 @@ config("optimize_max") {
  #
  # TODO(crbug.com/621335) - rework how all of these configs are related
  # so that we don't need this disclaimer.
@@ -136,7 +136,7 @@ index d4597c7..4c651ac 100644
    if (is_nacl && is_nacl_irt) {
      # The NaCl IRT is a special case and always wants its own config.
      # Various components do:
-@@ -2096,7 +2071,8 @@ config("optimize_speed") {
+@@ -2091,7 +2066,8 @@ config("optimize_speed") {
    }
  }
  
@@ -146,7 +146,7 @@ index d4597c7..4c651ac 100644
    cflags = [ "-O1" ] + common_optimize_on_cflags
    ldflags = common_optimize_on_ldflags
    visibility = [ ":default_optimization" ]
-@@ -2212,7 +2188,8 @@ config("win_pdbaltpath") {
+@@ -2207,7 +2183,8 @@ config("win_pdbaltpath") {
  }
  
  # Full symbols.
@@ -156,7 +156,7 @@ index d4597c7..4c651ac 100644
    if (is_win) {
      if (is_clang) {
        cflags = [ "/Z7" ]  # Debug information in the .obj files.
-@@ -2318,7 +2295,8 @@ config("symbols") {
+@@ -2313,7 +2290,8 @@ config("symbols") {
  # Minimal symbols.
  # This config guarantees to hold symbol for stack trace which are shown to user
  # when crash happens in unittests running on buildbot.
@@ -166,16 +166,16 @@ index d4597c7..4c651ac 100644
    if (is_win) {
      # Functions, files, and line tables only.
      cflags = []
-@@ -2373,7 +2351,8 @@ config("minimal_symbols") {
- }
- # No symbols.
+@@ -2370,7 +2348,8 @@ config("minimal_symbols") {
+ # This configuration contains function names only. That is, the compiler is
+ # told to not generate debug information and the linker then just puts function
+ # names in the final debug information.
 -config("no_symbols") {
 +config("no_symbols") { }
 +config("xno_symbols") {
-   if (!is_win) {
-     cflags = [ "-g0" ]
-     asmflags = cflags
+   if (is_win) {
+     ldflags = [ "/DEBUG" ]
 -- 
 2.24.1