dev-python/jupyter_client: drop py2
authorVirgil Dupras <vdupras@gentoo.org>
Sat, 4 May 2019 20:42:48 +0000 (16:42 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Sat, 4 May 2019 22:58:03 +0000 (18:58 -0400)
Bug: https://bugs.gentoo.org/685040
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild b/dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild
new file mode 100644 (file)
index 0000000..470782f
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/traitlets[${PYTHON_USEDEP}]
+       dev-python/jupyter_core[${PYTHON_USEDEP}]
+       >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+       "
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/ipykernel[${PYTHON_USEDEP}]
+       )
+       "
+
+python_test() {
+       pytest -vv jupyter_client || die
+}