app-editors/sandy: Add IUSE=savedconfig
authorJeroen Roovers <jer@gentoo.org>
Wed, 13 May 2020 07:56:38 +0000 (09:56 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 13 May 2020 07:56:49 +0000 (09:56 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
app-editors/sandy/sandy-0.4-r1.ebuild [new file with mode: 0644]

diff --git a/app-editors/sandy/sandy-0.4-r1.ebuild b/app-editors/sandy/sandy-0.4-r1.ebuild
new file mode 100644 (file)
index 0000000..d6f94b3
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic savedconfig toolchain-funcs
+
+DESCRIPTION="an ncurses text editor with an easy-to-read, hackable C source"
+HOMEPAGE="https://tools.suckless.org/sandy"
+SRC_URI="https://git.suckless.org/${PN}/snapshot/${P}.tar.bz2"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+       sys-libs/ncurses:0=
+"
+RDEPEND="
+       ${DEPEND}
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.4-gentoo.patch
+)
+
+src_prepare() {
+       default
+       restore_config config.h
+}
+
+src_compile() {
+       tc-export CC PKG_CONFIG
+       append-cflags -D_DEFAULT_SOURCE
+       emake PREFIX=/usr ${PN}
+}
+
+src_install() {
+       emake PREFIX=/usr DESTDIR="${D}" install
+       save_config config.h
+}