dev-java/jibx: add a SLOT to jibx-1.2.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 7 Jul 2017 12:26:25 +0000 (14:26 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 7 Jul 2017 16:18:42 +0000 (18:18 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.1
RepoMan-Options: --force

dev-java/jibx/jibx-1.2.6-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/jibx/jibx-1.2.6-r1.ebuild b/dev-java/jibx/jibx-1.2.6-r1.ebuild
new file mode 100644 (file)
index 0000000..3a2db81
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bind XML to Java code"
+HOMEPAGE="http://jibx.sourceforge.net/"
+SRC_URI="
+       https://repo1.maven.org/maven2/org/${PN}/${PN}-extras/${PV}/${PN}-extras-${PV}-sources.jar
+       https://repo1.maven.org/maven2/org/${PN}/${PN}-bind/${PV}/${PN}-bind-${PV}-sources.jar
+       https://repo1.maven.org/maven2/org/${PN}/${PN}-run/${PV}/${PN}-run-${PV}-sources.jar
+"
+
+LICENSE="BSD"
+SLOT="1.2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+CDEPEND="
+       dev-java/bcel:0
+       dev-java/xpp3:0
+       dev-java/jdom:0
+       dev-java/dom4j:1
+       dev-java/log4j:0
+       dev-java/joda-time:0
+       dev-java/ant-core:0"
+
+RDEPEND="
+       ${CDEPEND}
+       >=virtual/jre-1.6"
+
+DEPEND="
+       ${CDEPEND}
+       >=virtual/jdk-1.6"
+
+JAVA_GENTOO_CLASSPATH="
+       joda-time
+       ant-core
+       dom4j-1
+       log4j
+       jdom
+       bcel
+       xpp3
+"