dev-python/sympy: Restrict ipython to py3
authorMichał Górny <mgorny@gentoo.org>
Tue, 3 Dec 2019 09:57:05 +0000 (10:57 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 4 Dec 2019 17:13:35 +0000 (18:13 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sympy/sympy-1.0-r1.ebuild
dev-python/sympy/sympy-1.3.ebuild

index f75311b5dad121d337c8a4fd2d50b614389790ee..719584259fe746daeb4004530223506fe3d88c9c 100644 (file)
@@ -17,12 +17,13 @@ KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet test texmacs theano"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+       doc? ( || ( $(python_gen_useflags 'python2*') ) )
+       ipython? ( || ( $(python_gen_useflags -3) ) )"
 
 RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/pexpect-2.0[${PYTHON_USEDEP}]' python2_7)
        imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
-       ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+       ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
        latex? (
                virtual/latex-base
                dev-texlive/texlive-fontsextra
index 963538ab3acf8c926f94463821024f0fc820a5a4..03a1e064eab0971f1ca83b33fbea28e042556bee 100644 (file)
@@ -17,7 +17,8 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+       doc? ( || ( $(python_gen_useflags 'python2*') ) )
+       ipython? ( || ( $(python_gen_useflags -3) ) )"
 
 RESTRICT="test"
 # All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +27,7 @@ RESTRICT="test"
 RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
        dev-python/pexpect[${PYTHON_USEDEP}]
        imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
-       ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+       ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
        latex? (
                virtual/latex-base
                dev-texlive/texlive-fontsextra